#$*&&^` grass clumps, revisited

Started by Harvey Birdman, March 21, 2007, 03:10:38 am

Previous topic - Next topic

Harvey Birdman

Hey, Oshyan et al -

I never was able to get entirely satisfactory results with the terrain I was working with earlier (heavily displaced procedural, with the local surface at large negative elevation). I was never able to get the grass blades on scale, have them sit on the terrain and match up with their shadows all at the same time. Something or other was always wrong, and there seemed to be, under those conditions, anyway, a completely non-intuitive connection between vertical offset, scale, and where the grass actually appeared. I even tried adjusting the displacement offset so the local terrain was close to zero elevation, but no luck.

This afternoon I created a hieghtfield-based terrain, applied some surface shaders, set up the grass clumps and voila! perfect. I feel better, but I wish I could figure out how to get it to work on the first terrain. I'll probably keep plugging at it.

Oshyan

Thanks for the update. I'm glad to hear you were able to get it working at least with a fairly simple scene. There is still some tuning to be done to make it easier to work at the extremes of planetary terrain scales. Hopefully some of this adjustment will help with your problems.

- Oshyan

DiscoBall

Hmm..Oshyan, u say 'extremes'...

Maybe the terrain was so steep, and since objects are 'dropped' onto the terrain, maybe the objects , since the terrain was so steep,were dropped to a part of the terrain where it was not so steep?

Eg. Near 90 degree angle steepness, and the objects, trying to be put at the top of the cliff, were actually put down near the middle/bottom of the cliff/terrain where it was not so steep..

I don't know, but I am assuming the objects are dropped vertically.

Harvey Birdman

No, the terrain in question was reasonably flat in the area I was trying to apply the grass. I could get it to appear below the surface and set the blade length so it pierced the surface, but there was no precision - some areas had none appearing, others had plenty, others had shadow but no grass, etc. It was difficult to figure out. Well, for me, anyway.

:)

DiscoBall

Mm..post a tgd here and let us have a look :P

Or have you already posted one? And did it not work?
There must be..some..error..or maybe the obj your working with isnt really working ;)

RedSquare

@ DiscoBall.  I think you'll find it worth while reading this thread...http://forums.planetside.co.uk/index.php?topic=1094.0   ;D

DiscoBall

Oh I see..grass clumps eh..lol

Try usinggggg an obj grass - they're much better.
Search around, there's a topic just on grass. If not, then search for 'cut_lawn'
^ ^

And maybe it seems that it was because your terrain was vastly below normal level and thus did not work :S

However, since it's working now, congratulations! :)