Unexpected surface layer behavior *Solved*

Started by Mohawk20, December 26, 2010, 10:05:59 AM

Previous topic - Next topic


Hi guys!
I haven't been online much lately, but I have been rendering away.
I decided to revisit an old Canyon scene I never finished.

The problem I have with it is that I wanted veins of copper to peek through the side of the walls here and there.
But whatever I try, even though the preview render, and even the GI pre-pass look promising, the final render has no veins, but full coverage.
Maybe I'm just blind, stupid, and missing something, but I've attached the tgd file and a render to show what I get, and a PhotoShop mock-up of what I want.
Could you please take a look at it?

I changed the copper to emit light, so it's easier to spot it. So where the white light is, is where I want the copper coverage...


This at least takes care of part of your problem, but why your fractals won't work I couldn't figure out. You did have some extreme displacements, maybe it's that. And some extreme luminosity, which I changed to a more subtle green copper, which you might want to change back if you want them to really light up. Anyway, the voronoi veins work at least. You can change the width and size, of course.


The voronoi was my backup plan.

I just wanted to know why the fractals wouldn't work, so I can avoid that problem a next time...
And the luminosity was only for testing purposes, so I would have changed it anyway.

Thanks though for taking the time to look at it, and for creating a solution!

Can someone from Planetside take a look at this in a bug related way, or do I have to make a separate bug report for that?


Dunes solution fixed the problem, so thanks again!

But now I run into another problem that shouldn't be occurring...
I have only a few surface layers, and I wanted to add one.
I had a surface layer for rocks, and decided that is would be good to give it a child layer.

- But I can't -

I mean, I can, but then the hightfield disappears.
When I create a surface layer node, and plug it into the 'child layers' input of the rocks surfaceshader, the height fields disappear from the preview window.
When I unplug it, they reappear.
And it's not just the preview window. I rendered it with the node attached and the render had just flat surface.
I think this counts as a bug.

I tried adding a child in the Shaders tab menu, but that gave the same result.
Placing the new surfacelayer below the rocks shader fixed the problem, but it still shouldn't happen.

Below are some images.
First is the node view, with the problem shaders circled.
Next is what the scene looked like,
and below that is what the bug's result looks like.
I also included the tgd file


The 'intersect underlying' function of that new child surface layer is what's cancelling out the terrain. Unchecking that option brings it back to life.

I imagine that since the surface layer has no 'underlying' shaders(nothing is plugged into its input) then it isn't working as you'd expect. Inputting the compute terrain node into that layer will make the IU features work.


Dude, you're totally right.
Man I'm getting old or something...

Never mind me!
I have just been using TG too little lately.

Thanks for the help Dandel0!
I'll remove the BUG part, and replace it with Stupid or something.