32-bit version still comes up after installing 64-bit edition

Started by PabloMack, April 24, 2011, 09:59:05 am

Previous topic - Next topic

PabloMack

When I double-click on an existing project, the 32-bit version is loaded even though the 64-bit version comes up when I click the application's icon. Should I have uninstalled TG2 before installing the new 64-bit edition? If so, should I uninstall the 32-bit version with the 64-bit version installed?

Henry Blewer

The program icon is still pointing to the 32 bit version. Just copy the new icon to the taskbar or the desktop. Then remove the old one.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

Oshyan

Sounds like it's a file association problem rather than a shortcut issue. We do normally recommend uninstalling previous versions before installing new updates. In this case it's particularly important (unless you want to maintain the old 32 bit version for some reason) because the 64 bit version will usually install in a different location on 64 bit Windows. Due to that, you've ended up with two versions installed simultaneously. The best course of action would be to uninstall *both*, then reinstall 64 bit only. Alternatively you could simply reassociate TGD with the 64 bit exe which will now be located in C:\Program Files\Planetside Software\ whereas the 32 bit version would be C:\Program Files (x86)\Planetside Software\.

- Oshyan

PabloMack

Turns out I had four TG2 versions installed. I uninstalled them all from the Administrator account. I then installed the 64-bit version. The Administrator can now run the program by clicking on a TGD file's icon. I then went into my user account that does not have administrator priviledge. Now when I click on a TGD file it opens it up in Notepad. When I try to associate a TGD file with the new executable, I click Open in the file association program after "browsing" to it. The window goes away and Notepad is still the program that is associated with it. I tried again after giving Administrator privilege the user account that I do my applications in and it still doesn't accept the new file association. I don't do application work in the Administrator account for security reasons. Now why can't I associate a TGD file with the TGD executable in my user account? Perhaps this is a Windows-7 issue. I will try installing it in my user account but this is something I don't like to do.

I removed TG2 and then reinstalled it in my user account which I gave Admin privilege just to do the install. It still doesn't let me associate the TGD.EXE file with *.TGD file extension. I am dreading having to deal with MS tech support on this one. Any ideas?

Oshyan

Not sure how to address that issue I'm afraid. It's not something I can reproduce here with my current setup (though I'm also on Win7).

- Oshyan

PabloMack

Previously, I had installed the TG2-64 from the Administrator's account and checked "Used by Everyone" instead of for use only by that one account. This time, after installation was complete, when I right-clicked a TGD file and selected "Open With", the Terragen 2 program showed up as an option for the first time. Apparently I am the only one who is installing the programs in my Administrator account and selecting it to be used by everyone. I suspect that I just ran into a deficiency in the TG2 installer. However, I still can't explain why W-7 would not let me associate the file extension with the program that I was able to navigate to and select.

Kadri


I had the same problem. I use Windows 7 64 bit Ultimate .
Trying to change the file association by clicking on a TGD file with the right mouse button and selecting properties and so didn't worked!

But this worked without a new install : http://pcsupport.about.com/od/fixtheproblem/ht/default-program-windows-7.htm



Henry Blewer

The newer 64 bit version will install in a different program directory. Programs x86 or something. You'll need to create a new shortcut to it.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

Klas

Quote from: Kadri on July 06, 2011, 08:14:41 pm

I had the same problem. I use Windows 7 64 bit Ultimate .
Trying to change the file association by clicking on a TGD file with the right mouse button and selecting properties and so didn't worked!
Rename the new tgd.exe to something different (tgd23020.exe), then change the file association.

billg60

I had the exact same experience on two separate Win 7 64 bit machines. Your fix worked - thanks!!! Driving me crazy ???