Buttons stop functioning

Started by ProjectX, April 01, 2007, 12:52:42 pm

Previous topic - Next topic

Volker Harun

I agree with BigBen - having other applications open is a lifesaver.
When TG2 starts freezing, I shut down Firefox for example. TG2 is able to save a scene and to exit then most times.
Sometimes I need to shut down a second application and kill TG2 afterwards in the taskmanager. But saving always works.

Volker

nikita

August 05, 2007, 08:36:49 am #16 Last Edit: August 05, 2007, 08:43:28 am by nikita
I reported this (or a similar) one earlier: http://forums.planetside.co.uk/index.php?topic=130.0
I guess it's the same problem.
(I use XP)

chaps

Of course I have the same problem,

Till now I was waiting, sometimes a lot, ant I was always able to save using the incon in the menu; then exit and restart.

I will try to shut down some application next time, it is may be faster.

I don't think it is a memory leak, the task manager do not show any evidence of it.

As a side effect, I have sometime windows with is affected: I cannot call the task manager, or switch to another application.

Last, very often, the keyboard is switched from french to english, very bad to type a number...


nikita

Quote from: chaps on August 07, 2007, 11:15:20 amLast, very often, the keyboard is switched from french to english, very bad to type a number...

Some of the keys to navigate in the preview are used by windows to switch the locale. (this setting where you can choose the keyboard layout for your language)
You can turn these hotkeys off by right clicking the locale panel (a blue square in your task bar with an abbreviation of your country's name, in your case "FR")
Choose "Settings...", click "key board" "Change Hotkeys" and disable everything.

I hope this helps.. i have a german XP, so I had to try and translate those dialogs.

chaps

I made the change, didn't check it now, but i'll tell you if it is OK.

Thanks.

jo

Hi,

On the subject of problems with key combinations and keyboards switching locales, we're very sorry to hear that. At the moment, strictly speaking, we only support TG2 on English versions of the OS. However we are making efforts to improve this. For a start, the key/mouse bindings will eventually be user configurable. The system is designed to work across different locales. The basics are there, but we still need to create a configuration interface for it. This will allow more suitable key bindings to be used on different OSes. Once we have it up and running, hopefully we can get feedback and build a collection of key binding sets for each locale and then load the appropriate set by default for that locale.

Regards,

Jo

nikita

It is LeftAlt+Shift to switch the Locale Settings and Strg+Shift to switch the keyboard layout in the german Version of XP... I don't think these are much different in other xp-versions.
The reason this wasn't noticed earlier might be, that the english xp probably doesn't install other languages. So switching the locale does nothing.
In the german version you get german+english, so you have about 50% chance to have the wrong layout, but you probably won't notice that unless you use the "z","y" or number keys to name a shader.
I guess you'll notice that much earlier on azerty keyboards.

I didn't know that before running TG2 in the university. They have about 20 locales installed to have the right one for foreign students too, so if you switch layout there, you'll get Chinese, Arabian and such.

chaps

Disabling the hot key is a good workaroung for the keyboard issue.

And you are right, it is a problem on azerty keyboard, when you want to type a float, the dot is replace by a "<" and you must type ":" to get it....  ;)

bye

jo

Hi Chaps,

Quote from: chaps on August 09, 2007, 08:07:39 am
And you are right, it is a problem on azerty keyboard, when you want to type a float, the dot is replace by a "<" and you must type ":" to get it....  ;)


Is that if you've accidentally changed to a qwerty keyboard layout without realising it?

I tried an azerty layout using On-Screen Keyboard on Windows ( after I changed my keyboard settings to French ) and I seemed to be getting the correct characters.

Regards,

Jo

chaps

August 10, 2007, 08:49:50 am #24 Last Edit: August 10, 2007, 09:23:44 am by chaps
I can't say exactly which operation I was doing in TG2. In average i was doing:

* right click in the node area to insert new shader or function,
* double click on these functions to enter parameters,
* connecting them (very often I connect one output to an already connected input to modify the network but keep it valid, I don't know if it is usefull, but it seems to me that network errors are not totaly handled in the current version?)
Alt and Alt+Shift to move around (with maybe some illegal entry?)

!!!!!!! I get it, while I was writing this mail, I tried the different operations, and it occurs. the combination Alt+Maj swicth to  english.  As I understand the configuration menu, I should do Ctrl+Tab to modify the keyboard, I will do some test later.

Sorry, I made you waste your time.

Chaps.