tgdcli bug ?

Started by neon22, July 12, 2011, 10:54:58 PM

Previous topic - Next topic


Hi guys,
writing this rendering tool...
The attached tgd does render in TG2 but crashes in tgdcli when run from the batch file.
Using win7 64bit - 8 cores - 16 procs
Wonder if you know why it crashes in this way or can at least confirm it ?

as a hint - specifically the param I am changing is optimisation in "Big Clouds"
works for none, conservative, optimal - but crashes on "More acceleration"
Hmmm - used to be called Faster. I need to check my enumerated types for this option...

UPDATE: types are fine. The value stored in the tgd file is just the index into the enumerated list. labels are not imnprotant.

So crashes for me in tgdcli but renders in regular app usage. no idea why


How far through the render does it crash? Does it crash if you run tgdcli.exe manually, load the project, and render within the tgdcli GUI?
Just because milk is white doesn't mean that clouds are made of milk.


Quote from: Matt on July 18, 2011, 05:32:20 PM
How far through the render does it crash? Does it crash if you run tgdcli.exe manually, load the project, and render within the tgdcli GUI?

well did not know you could do that. it looks identical to the regular GUI...
So I tried the following tests:

1. Calling tgdcli from a cmd shell without all the extra cruft in the .bat file
I.e. handcrafted command as follows:
C:\Users\user3\Documents\Rendering>"C:\Program Files\Planetside Software\Terragen 2 Deep Edition\tgdcli.exe" -p "tmpCloud Test 5_Blend-1_cloud_laye_Density fr_cloud_alti_2200_50_Faster-busted.tgd" -r -f 1 -o junk.bmp

- in this case it worked and created the outputfile before halting with error as c:Temp does not exist on win7 64 bit machines.
but otherwise successful
Rendering final pass... 0:13:30s, 591547 micro-triangles
WriteBMP: attempting to write file
WriteBMP successful
WriteBMP: attempting to write file
ERROR: WriteBMP: Unable to open file!

Possible causes: folder doesn't exist or disk full.
ERROR: Permission denied
Finished rendering: 0:13:33s, 645445 micro-triangles
Destroying trPrivateGlobals

2. So tried running tgd_batch.bat from same command line
Hmmm.. worked... what's going on... not expecting that

3. Running tgd_batch by double click the .bat file in explorer but did not crash.
weird. I had renamed the referenced batch file in the meantime.
which suggests there was something wrong in the characters in the .bat file...
because it broke every single time I tried it the other day..  :(

4. Also tried running tgdcli.exe - which gives a GUI exactly like the regular tgd.exe
- manually loaded the tmp...tgd file and rendered into a window
worked fine same result image as 1 - took about the same time as 1.

So now I'm really perplexed. because its now running to completion....
so I guess you need to cancel this as a bug report and I wil keep trying to get a repeatable bug....