Object Errors

Started by rcallicotte, April 08, 2007, 10:39:53 am

Previous topic - Next topic

rcallicotte

I've been seeing these a lot.  The texture is 3000X3000.  There are 13 objects (lucky number 13!) which all share some of the same common textures.  Perhaps this is why; I don't know.  I needed all 13 objects to make a rider on a horse.
Memory was at 1.24G at the time and I only have 2G.  Only a couple of other windows open - IE and Windows Explorer.
So this is Disney World.  Can we live here?

Harvey Birdman

April 08, 2007, 11:14:24 am #1 Last Edit: April 08, 2007, 11:20:04 am by Harvey Birdman
This is a wild guess, but it could be referring to video memory instead of system memory. All the textures you're loading may have exceeded the amount of RAM on your video board. I thought Windows was supposed to use system memory if it ran out of video memory, but who knows. Try reducing the texture size to 2048x2048, if possible (magic number!   ;D  ). Like I said, wild guess.

rcallicotte

Harvey, I might try reducing the size of my texture image, though I thought TG2 was supposed to be relying more on system RAM than my video RAM and yet AGP makes that inseparable I would guess.  Anyway, I think it should have handled it. 

Maybe I'm wrong.  Oshyan...anyone at Planetside...?
So this is Disney World.  Can we live here?

Harvey Birdman

You're probably right. I go away.

;)

Oshyan

Video memory should not be a significant factor. I would guess it's the large size of the texture combined with other elements of the scene's memory use and/or general available system resources. The error indicates TG2 is unable to allocate enough memory for an image buffer. Do you get this error when you load the texture or when you try to render?

- Oshyan

rcallicotte

Oshyan - only during the render and it doesn't always happen.  Usually, but not always, it's when I'm up close on the object with the camera.  But, then again, not always.  And it's always the large textures (3000X3000).
So this is Disney World.  Can we live here?

Oshyan

If it's during the render then it sounds more like it's related to your render resolution itself. What resolution are you trying to render at?

- Oshyan

rcallicotte

It was 1200X900.  Not too much.  I still think it's how the size of the texture is being handled.  But...maybe this will help - In one shot the object itself is minuscule and in the other the object was right there in the forefront.  Both had the problem.  Somewhere in between seemed less prone to this error.  I've seen this matter in another scene I was doing, when I moved the object to the very forefront. 

What can I tell you about this that will actually help?  Let me know.
So this is Disney World.  Can we live here?

Oshyan

Hard to say - it's odd that it occurs at both near and far distance but not in-between. Given the relatively reasonable render resolution I think you're right that it is due to the texture size. In fact if you calculate the size of that texture at 24bit/pixel it is 27,000,000 bytes, so the message surely refers to that. Resizing the texture should help. It sounds like it's just an overall memory allocation problem. Memory management for larger textures will definitely be improved in the future.

- Oshyan