TP crashing windows

Started by nikita, December 23, 2006, 03:55:00 pm

Previous topic - Next topic

Oshyan

Did you encounter this after a long period of use? Can you reproduce it consistently? Did you happen to check memory use at the time? Were you running any other significant applications?

- Oshyan

Harvey Birdman

March 25, 2007, 08:28:42 am #16 Last Edit: March 25, 2007, 08:35:33 am by Harvey Birdman
Oshyan -I can report similar symptoms, but I can't give specifics as to system memory status, etc; I afraid I was caught a bit off guard. It definitely looks like a memory leak. After a long session, property pages became blank - TG seemed unable to create child controls. I tried starting another app (don't recall what) and windows reported it was unable to start the application because of low system memory (!). Quitting the program did not release the system, although I admit to being a bit short of patience and rebooting after a couple of minutes.

rcallicotte

I haven't crashed Windows, but I have seen that after awhile on the previous version that I would run out of resources, which caused menus to stop functioning and previews to stop.  It was usually after a long duration of time with the window of TG2 open.  Of course, I would have other things going on at the same time (email, surfing the net, Word...)

I haven't seen it since the new release came out.
So this is Disney World.  Can we live here?

helentr

Hello,

I have seen this behaviour both before and after the update.
Menus would not open, submenus would not appear. A few times it would appear suddenly, following a flickering of the screen, but most often it followed after keeping Terragen open a long time and making many changes, alternating tabs etc. The most usual event that started it was when I tried a different seed in a population, checked the "preview" button, unchecked and tried again. After a few times of this, the GUI stopped responding.
Minimizing Terragen for a few minutes, sometimes restored the problem, but it was unsteady afterwards. Once I tried rendering after the function was restored and the rendering stopped as soon as it began. The window caption was: "Rendering (0:0:01s)" and the CPU usage was 0%.

Most often there was no memory or resource problem and if I started other programs, they worked as usual. But, there was a similar problem on the desktop, when Terragen was that way. Right clicking and double clicking did not work. Only the tray menu programs could start, which did not need double clicking. The desktop came to normal, as soon as Terragen closed or was closed by Task manager.

I thought it might be a problem with the visual something used to make the GUI - maybe I don't have the right version of the runtimes or it is corrupted.

Helen

Oshyan

Thanks for the reports folks. We'll look into these issues for fixing in a future update.

- Oshyan

bigben

March 25, 2007, 11:24:09 pm #20 Last Edit: March 25, 2007, 11:27:15 pm by bigben
I've had similar experiences to Helen.  Usually right-clicking doesn't work and/or menu selections do nothing in both TG and other apps. Luckily I usually have another program like Photoshop running at the same time so I shut down the other app which gets things working again, save my work in TG and close TG.

This seems to be enough to free up resources again to start another session.  I don't think it's a RAM issue as RAM usage was not suspiciously high (not higher than expected).  On the plus side, since the update I've had far fewer occasions where the display has started failing to redraw on screen.