Black frames output when rendering sequence

Started by digitalis99, December 11, 2011, 12:35:11 pm

Previous topic - Next topic

Kadri


I do not know the others but it could be what you say on my end here.
I have some kinda extreme displacements that i am suspicious of .
And now i get this :


[attachimg=#]


Probably nothing major as you say.

Oshyan

Is memory use very high when you get those errors? They look like possible memory problems. You cold also try increased displacement tolerance in the Planet node, potentially.

- Oshyan

Kadri

April 01, 2012, 01:36:06 am #17 Last Edit: April 01, 2012, 01:39:49 am by Kadri

No. It is 2.4 gb mostly.
I have 4 gb ram , windows 7 64 bit.

I tried some basic things:

When i click on the " Cameras "  button over the 3d preview window and wait nothing happens(no error).

When i click on the " Renderers " button the preview windows does not draw all things alright at the end(similar to the real rendering) and the error comes up.

I tried it with the other buttons and it seems related if the Atmosphere is drawn or not in the preview .
If i trigger a redraw that does not render the atmosphere  i get no warning and no problem with the preview.

I bypassed one node tree and it did go away. It is scene specific as we thought  :)

But it is interesting that it can so much wrong.
I will try a GI render too. Just to test if it will render OK without that node tree Oshyan.


Oshyan

Frankly, with "only" 4GB of RAM, it still could easily be memory-related at 2.4GB of memory used. Windows 7 typically uses a GB or so just for system files in memory and basic services. Not to mention other things which are very commonly running in the background, not even active applications - Antivirus, Dropbox, iTunes, etc. Check your *free* memory, what does that show? What do you see on your memory use graph, is it peaking?

- Oshyan

Kadri

April 01, 2012, 02:20:08 am #19 Last Edit: April 01, 2012, 02:35:30 am by Kadri

With the last iteration of the scene the free part of memory is near 300-400 mb (it was 300 mb nearly the most at rendering ) in the task manager and no drastic peaks.
It steadily goes up mostly .

The render finishes OK with GI .
The preview window is problematic now (with the node tree on) .

It is manageable for me in this state so not much of a problem .

Maybe a basic thing like a fresh start of Windows could help Oshyan ? :)
Will try it a hour or so later .

Oshyan

Hehe, could be. Problems with the 3D preview are usually driver/graphics card related though. Sounds like there might be multiple things going on, hard to say. It's possible memory use did peak and some hasn't been released, or it's now fragmented and having allocation issues. A reboot would fix all that. That could be at the root of multiple different issues such as you're experiencing, and I can't think of any other likely explanation (unless it's just coincidence).

- Oshyan

Kadri


I think i found the real problem Oshyan.
I looked at the problematic node tree and found that i have "Intersect underlying" checked .
When OFF i get no warning in the preview only with ON.


Oshyan

Ah interesting. I seem to recall some circumstance where that occurs, but I don't remember the details...

- Oshyan


Matt

Quote from: Oshyan on April 01, 2012, 01:15:22 am
You cold also try increased displacement tolerance in the Planet node, potentially.


That would be unrelated. Low displacement tolerance will not cause errors like this (at least not in current versions). If it's too low, the worst that can happen is that the rendered image won't look right, as it misses surfaces that are displaced more than it expects, or leaves gaps in shadows of displaced surfaces.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Kadri

April 01, 2012, 04:04:03 am #25 Last Edit: April 01, 2012, 04:06:18 am by Kadri

Forget to mention that i tried that ( displacement tolerance in the Planet node) too , but the error did not go away then.

engineer

April 05, 2012, 10:46:06 am #26 Last Edit: April 05, 2012, 10:52:50 am by engineer
Quote from: Oshyan on April 01, 2012, 01:00:27 am
I don't know if this was ever reproduced on our end. I'll check with Jo. Having rendered a tremendous number of sequence frames (literally 10s of 1000s), I have a hard time not suspecting the specific scene setup rather than some intermittent bug in TG's sequence output.

- Oshyan


I have a very similar, maybe the same issue within a project.
TG2 does render OK, then a minor change and the rendere result is just black.
Interesting is that the preview as well as the pre-pass are looking OK and even the change made seems to have worked.
And the type of change seems to be un-important: I have changed camera position or surface displacement or colouring or whatever. The result is always the same: black picture...
[edit on]
To be a bit more exact: the result is not always the same, some pictures were rendered. But the black render result shows up and when it does, the change before was whatever it was. So TG2 became a bit "unpredictable"...
And the probability, that this happens, seems to be increasing  :'(
[edit off]

So I am really interested in whether there is something like a common reason found for these black renders.

Oshyan

Every time we've seen a "black render" issue, there is a cause in the specific settings of the scene. It's not really a renderer error, from what we've seen. Are you perhaps using extremely small scale values in a Power Fractal (smaller than 1 cm, or 0.1)?

- Oshyan

engineer

indeed, I've had a couple of PF's with small scale values (downto 0.001).
After changing this to a min value of 0.01 the scene was rendered normal or with a non-black result.
So thanks for the hint.

Quote from: Oshyan on April 05, 2012, 10:21:48 pm
Every time we've seen a "black render" issue, there is a cause in the specific settings of the scene. It's not really a renderer error, from what we've seen.

Why are you calling small scales in PF's a "specific setting in the scene"?

As long as there is no hint or documentation stating that these values could lead to unexpected render results, they are simply allowed and any unexpected result is an error.

By the way, there was just the opposite stated: use scales in line with the sizes of items.
Now sand has scales below 0.01, even 0.001 won't be right always.

Happy Easter

Dune

I never use a scale smaller than 0.005, after having the same problem in the beginning. Anyway, even for extreme close-ups you'd need good glasses to see such fine detail in real life, so it's hardly any use using smaller scales.