mac mini core solo

Started by tomatomic, April 25, 2007, 08:56:33 pm

Previous topic - Next topic

tomatomic

April 25, 2007, 08:56:33 pm Last Edit: April 25, 2007, 08:58:48 pm by tomatomic
strange, doing tests on different computers low detail, and on the mac core solo, the red/orange terrain is coming in totally green.
only this mac.. on several others, all the same output.

in nodes i see fractal breakups, fractal terrains, in shaders i see power fractal shaders, twist and shear, fractal breakup, surface layers, fake stones.. (i didnt make this)

wish i could share the scene file, but for legal reasons, i just cant. :-(

tomatomic

oops, its repeatable, and on 3 different intel macs now..
my macbook pro (core duo), mac mini core solo, imac core duo.. seems a mac intel issue.. whats strange is as it renders sequences of an animation, 1 frame is corrrect, the next a totally green hue where there should be red/orange... seems random from 1 frame to the next.. where in the sequence, the frames are very similar to each other.. so.. no mac intel in this render pipeline :-D

Oshyan

Does it only affect surfaces? Do you have GI enabled?

- Oshyan

tomatomic

yes possibly, i think its the planet surface only, and yes GI is enabled, though low settings.
i went back after it completed rendering to try and re-render the frame, it insisted on rendering green. i have a slightly animated light.. when i changed the heading of the light slightly (x.61 to x.7), it rendered properly - the orange cast in the scene settings.. its still a tad random on the fix tho, same setting 2 times, once green, once orange. strange.

and still, only mac intel. i have rendered on G5s and 3 opteron windows boxes, and never a green frame wiht the same scene

Oshyan

Try turning off GI entirely (set both GI settings to 0 in render settings) and see if it still renders green.

- Oshyan

tomatomic

yes.. that did it.. gi = 0 made it the proper color..
so i guess some sort of bug with mac intel and GI puts on green spectacles?

;)

Oshyan

There are a number of odd GI issues in the system right now. This sounds like the most specific reproducible instance I've heard of though. If you could forward the .tgd to support@planetside.co.uk we can probably make use of it to diagnose the problems.

Thanks!

- Oshyan