Problem rendering with Planet Shader (Mac)

Started by trailgirl, May 14, 2007, 01:35:09 pm

Previous topic - Next topic

trailgirl

I am using a planet shader on a fractal terrain. I can't get a proper render although the preview looks fine. I haven't changed any of the settings in the shader. I had the atmosphere quality at 64 then changed it back to 16, still get really strange renders. Sometimes the Preview window also shows the weird coloring but goes back to normal with "reset". Sometimes the preview window turns a solid bright blue. I've tried quitting and restarting Terragen several times, and I've tried both Full Render and Quick Render. I'm on an iMac, 10.4.9, intel core 2 duo, 1GB memory, 2GB processor. Latest TG2 (build 1.8.76.0)


old_blaggard

 I think that this is a global illumination issue.  Try turning GI to 0/0 in one of your render nodes.  This sounds like a fairly simple scene, so I don't know why GI would be struggling, but from your screenshots it looks like the most likely candidate.  Let us know if that helps.
Nice setup, by the way - I'm still stuck on a G4 PowerBook :(.
http://www.terragen.org - A great Terragen resource with models, contests, galleries, and forums.

trailgirl

Thank you, old_blaggard. You are right, I changed the GI setting to 0 and it did render properly. Then I played around with the settings, and it seems to be the "GI relative detail" that is the problem, if I change it to 0 it renders fine, even with the GI sample quality set to 2.

Oshyan

There are some known issues in the way that GI is calculated that can sometimes cause errors like this. As o_b said your scene doesn't seem like one that should cause it, but it does seem somewhat random. These problems will of course be fixed in the future.

- Oshyan