Can't Start 2.4 on Mac

Started by whitIL, September 30, 2012, 12:56:25 am

Previous topic - Next topic


I just tried to use the Free 2.4 version on my Mac. Every time I try to start the program it fails and I get a message saying that it has "quit unexpectedly." I have never gotten it to run.

Information about my computer and error messages, etc. below

Thanks for any insight.


Mac 10.5.8
Dual 2 GHz PowerPC G5
4.5 GB Ram
GeForce 6600LE (using 2 displays)

Console Log:
9/29/12 10:59:04 PM [0x0-0xd21d21][82180] dyld: Library not loaded: /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit
9/29/12 10:59:04 PM [0x0-0xd21d21][82180]   Referenced from: /System/Library/Frameworks/GLUT.framework/Versions/A/GLUT
9/29/12 10:59:04 PM [0x0-0xd21d21][82180]   Reason: no suitable image found.  Did find:
9/29/12 10:59:04 PM [0x0-0xd21d21][82180]  /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit: no matching architecture in universal wrapper
9/29/12 10:59:04 PM [0x0-0xd21d21][82180]  /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit: no matching architecture in universal wrapper
9/29/12 10:59:05 PM[84] ([0x0-0xd21d21][82180]) Exited abnormally: Trace/BPT trap
9/29/12 10:59:05 PM[82182] UserNotification[82182]: [WSX] Will not load into as the hard coded exclude list says no.
9/29/12 10:59:05 PM[82182] UserNotification[82182]: [WSX] Will not load into as the hard coded exclude list says no.

Console Crash Reporter:
Process:         Terragen 2 [82180]
Path:            /Applications/Terragen 2 Free Edition/Terragen 2
Version:         ??? (???)
Code Type:       PPC-64 (Native)
Parent Process:  launchd [84]

Date/Time:       2012-09-29 22:59:04.793 -0500
OS Version:      Mac OS X 10.5.8 (9L30)
Report Version:  6
Anonymous UUID:  D6477F47-1A77-493C-96AD-A1E0ADC9C572

Exception Codes: 0x0000000000000001, 0x00007fff5fc0105c
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit
  Referenced from: /System/Library/Frameworks/GLUT.framework/Versions/A/GLUT
  Reason: no suitable image found.  Did find:
   /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit: no matching architecture in universal wrapper
   /System/Library/Frameworks/QTKit.framework/Versions/A/QTKit: no matching architecture in universal wrapper

G5_Dual:A whit$ pwd
G5_Dual:A whit$ ls -la
total 14776
drwxr-xr-x   7 root  wheel      238 Aug  4  2011 .
drwxr-xr-x   4 root  wheel      136 Aug  4  2011 ..
lrwxr-xr-x   1 root  wheel       28 Aug  4  2011 CodeResources -> _CodeSignature/CodeResources
drwxr-xr-x  30 root  wheel     1020 Nov 15  2007 Headers
-rwxr-xr-x   1 root  wheel  7560128 Jun 25  2011 QTKit
drwxr-xr-x  85 root  wheel     2890 Aug  4  2011 Resources
drwxr-xr-x   3 root  wheel      102 Aug  4  2011 _CodeSignature


Hi Whit,

Thanks very much for reporting this problem. I've had a look into this and can confirm it. I'm not sure why this hasn't cropped up in my release testing. The problem is that Apple left out a crucial 64 bit PPC part of QuickTime in the Quicktime 7.6.6 update (which broke other 64 bit PPC applications too) and didn't even fix this problem in the later updates.

There are two ways you can work around this.

The easiest one is to use TG2 in 32 bit mode. Do a Get Info on the application and check the "Open in 32 bit mode" checkbox in the Get Info window. This does mean that TG2 will only run in 32 bit mode.

A more complicated solution would be to roll back QuickTime to 7.6.4. This should allow you to run TG2 in 64 bit mode. I haven't tried this myself and I'm not sure how it might effect other apps on your computer, so I'm not really recommending this, just mentioning it is an option. This seems to be what a number of people did when the QT 7.6.6 upgrade broke other 64 bit apps.

I will look into what can be done about this for the next TG2 update but I'm not sure there are a lot of options. It would have been best if Apple had fixed this problem!





Setting TG2 to 32 bit mode lets me start TG2.

Thanks for the help.



First, I'm not an actual user of this software, but I found this post while looking for the QTfix wrong architecture problem in relation to something completely different. It was quite helpful and thought I'd return the favor by detailing what I did with the information since it may help with other related issues (like mine) where simply changing to 32-bit doesn't work.

Indeed, the Quicktime 7.7.0 for Leopard update (a security update) is missing the ppc64 architecture in the QTfix library, compared to 7.6.4.
Although this is not ideal, what I ended up doing was extracting the Quicktime 7.6.4 Archive.pax.gz to a different location, then using
lipo (installed only if you have the developer tools) to create a new QTFix with only the ppc64 architecture (using the "-extract" option) in it, then again used lipo (this time "-create") to combine that with the QTFix library from 7.7.0, thus creating a QTFix with 7.7.0 code for the 3 architectures it already contains and having the older code only for the ppc64 fragment. Not ideal, but without 7.7.0 ppc64 code, it's probably about the best that can be done. While no security bug is unimportant and I don't wish to be too cavalier about it, the description implies that it's mostly important dealing with maliciously malformed input presumably downloaded from the web, and presumably that will load the newer fragments as the older code should only be used on things that really need it.