Orthographic camera not rendering populations?

Started by arlechinu, May 17, 2013, 09:36:45 AM

Previous topic - Next topic



I'm trying to render a terrain with a sphere population with a top-down ortographic camera but the population isn't rendered at all. Is this a bug or am I doing something wrong?

As soon as I change the camera from orthographic to perspective it renders everything ok. Thing is I need the orthographic render.

Edit: Forgot to mention I'm running Free Edition on a Mac, OSX 10.6 Snow Leopard.


Yes, it's a bug.

1) The built-in Sphere primitive can't be used in populations (regardless of camera projection), so I assume you are using an imported sphere.

2) There's a bug with orthographic rendering of "ray trace objects" and "ray trace atmosphere". Both of these need to be turned off for correct orthographic rendering. Turning off "ray trace objects" will cause the objects to be rendered using the micropolygon rasteriser, which works correctly in orthographic mode. Unfortunately this somewhat reduces the quality of objects and might also increase render time, but you can improve the quality by increasing the renderer's anti-aliasing and setting the Populator's "render quality" to "Very high quality" or "Ultra quality". The Populator's render quality setting only applies with "ray trace objects" is turned off.

Just because milk is white doesn't mean that clouds are made of milk.


Thanks for the quick reply!

However, I think I followed your advice but I still can't get the population to render. I've attached a screenshot of the preview area that shows the population and the render with the ortho camera as well as the render settings. Am I missing something or should I give up on the populator ? Any other way of planting lots of trees on a landscape?

Thanks again!


You're right. It's not working at all, whether ray trace objects is on or off. I will fix this.

There is a workaround. How perfect does your orthographic projection need to be? You can recreate a nearly orthographic view by placing the camera very high and zooming in. Try this: Choose Perspective mode. Set the focal length to 36000, and the film aperture to 36, 36. Now because the focal length is 1000 times the aperture, put the camera at a height of 1000 times the orthographic area you want to render. For example, if I want to render an area 500 metres on each side, I set the camera Y to 500000. With these settings the field of view is narrow enough that perspective distortion is almost non-existent, and you should get an almost perfect orthographic view.

Another way you can do this is to enter the orthographic area into the film aperture and then enter the height of the camera into the focal length, but you have to make sure the camera is high enough that this produces a very narrow field of view. You can ignore the fact that it's labeled in mm because the only thing that really matters here is the ratio of focal length to aperture (although the mm label will become important when we add depth of field rendering in future).

The only problem with this method arises if you need to place the camera closer to the ground for some reason, perhaps to change how the atmosphere is rendered, but hopefully you don't need to do that.

Just because milk is white doesn't mean that clouds are made of milk.


I'm trying to 'fake' an orthographic projection. More specifically, I set my orthographic camera at a -60 degree angle and distorted the terrain mask so that the final render matches a hex grid.

Your workaround seems to work with a perspective camera set at -90 degrees. As soon as I change that angle I can't seem to be able to find the terrain I generated anymore. At those extreme altitudes I figure even 1 degree change in the camera rotation changes the camera view by a lot.


One thing you could try is starting out zoomed out a bit more, then use the camera "look at point" button to specify where you want your camera to point (it's the little "eye" icon on the bottom toolbar beneath the 3D preview). Then just zoom in a bit more, re-do the look at point, and repeat those steps a few times until you're at the zoom level you want, with an accurate camera direction. Worth a try.

- Oshyan