shadow popping

Started by dorianvan, July 13, 2013, 07:54:43 pm

Previous topic - Next topic

Oshyan

Working on this via support email, in case anyone is wondering. Hopefully we can update with some final settings which improve the issue.

- Oshyan

dorianvan

So TG support suggested turning off Stabilize Ray Detail in Motion (render subdivision node), and enabling Lock Subdiv to Frame on the Extra tab and lock it to frame 1. I'd love to know what this technique does, but the result was no visible problems. The render time did increase so now I'll try lowering some of the other settings to offset it a bit. Thanks guys!
-Dorian

Oshyan

Glad that seems to have solved it. I'll let Matt chime in with explanation of what's going on.


I did forget to mention that for noise in vegetation you'll want to lower your AA noise threshold a bit and/or not use 1/64th adaptive (1/16th is probably OK). Unfortunately this will probably increase render time as well, but it's really going to be necessary for noise-free vegetation rendering. I think if you lower your detail down to say 0.65 you'll still get good results and can probably make up a good portion of the render time increase. There is a light source that has soft shadows and jitter is still at 1 with samples at 8, you could probably turn down samples a bit if you reduce jitter to the 0.2 level you have on other lights. At AA8 which you're using, you can probably be fine with fewer atmosphere samples, maybe 10 or even 8. You also *might* be able to get away with a lower Detail Blending value of 0.5. Also consider using the Voxel Buffer for localized clouds. All that should help on render time.

- Oshyan

dorianvan

Really good to know! Also looking forward to Matt's explanation if possible.
-Dorian

Dune

Sounds like you're off to render some interesting sequences now, Dorian. I'm glad things could be improved, the whole setting is really worth some fine footage!