Render Times jump from 1 to 6 hours from frame to frame

Started by ragnoru, March 03, 2014, 11:54:09 am

Previous topic - Next topic

ragnoru

I am running TG 3.1 I have not seen this in the previous release
the main difference between the computers is that the ones that are finishing the frames faster are workstations
they finish a frame in the the range between 1-2 1/2 hour, while our fastest machines range between 2 and 6 hours
this is a smooth animation so there is not a big difference from one frame and the other.
for example frame 283 and 284 is basically the same frame, one machine  from frame 283 is taking 3h:42min to finish the next frame with one of our faster machines is taking 6:47 minutes this is a huge jump it is pretty hard to manage a 400 frames shot we are talking about days to render one shot.
Is the new update penalizing "better" machines?
shot specs:
one set of localized  clouds , quality 1 depth 6500 noise flavour voronoi Billows
atmosphere quality 32
acceleration cache = NONE
no ground

renderer
image width 1600 900
detail 0.2
anti aliasing 3

camera
8704 Y
blur 0.5 -0.25


the settings are not crazy and I know that the voronoi Billows can be slow and that no acceleration cache can be
extremely slow, but without I get different color buckets!
any help will be appreciated.


Aldo

Matt

Hi Aldo,

Can you remote connect to the rendering slave and see what it's doing (if you're using Deadline) or check the render log if you're using some other system that gives you a realtime log?

It might be that it's got stuck at the end of the render for some reason, but it's hard to guess why without seeing a log.

If it's completing frames but just doing it very slowly, it might be useful to look at the logs to see where in the render it's spending the most time.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Matt

One other thing: just make absolutely sure that the frame logs say that the machine is running the correct version (it should be near the top of the log).

Matt
Just because milk is white doesn't mean that clouds are made of milk.

ragnoru

connected to the render machines (yes I do use deadline)
I have been monitoring these week-end, the frames do not seem to get stuck
right now I have frame 350 at at 4h:54min at 34%  let's call this machine an R class machine
frame 349 in a desktop machine was 2h:34 minutes
frame 351 on a desktop machine was 2h:11 minues

another frame 545 on onother R Class machine is at 83 % after 4h:12 minutes
frame 544 was 1h:06 minutes total
frame 546 was 1 h:24 minute

Class R is E5645 2.4 ghz machines

All running terragen 3.1

I turned the acceleration cache to conservative and the times are down to 20 min a frame but the flicker is not going to fly

Aldo

all machines running tg 3.1

ragnoru

Is there any way to use a different kind of acceleration and minimmize/eliminate the shadows flickers
20 minutes a frame compared to 8hours a frame would be a pretty good deal.
Aldo

Matt

In the log, search for a line that says "Number of buckets". Here's an example:

Number of buckets:   8 x 4 between 8 threads

The thing I'm interested in here is "between 8 threads". Check that that looks reasonable for the machine it's rendering on.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Matt

Quote from: ragnoru on March 03, 2014, 12:54:40 pm
Is there any way to use a different kind of acceleration and minimmize/eliminate the shadows flickers
20 minutes a frame compared to 8hours a frame would be a pretty good deal.
Aldo


If you're using localised clouds, try enabling the 2d shadow map.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Matt

Just because milk is white doesn't mean that clouds are made of milk.

ragnoru

from the log

2014-03-03 04:47:57:  0: STDOUT: Number of buckets:   13 x 8 between 24 threads
2014-03-03 04:47:57:  0: STDOUT: Largest bucket size: 124 x 113

let me know if you need more of the log.
Aldo

ragnoru

QuoteIf you're using localised clouds, try enabling the 2d shadow map.

Still get some shadow flicker same as with 3d shadows or very similar

Quote...or the Voxel buffer.

still flickers but just at the edge of frames(the camera has a noise applied to it's transformation)

also I am noticing (with the voxel buffer enabled and mind you could be user error) that the clouds have the same shape
but there are parts missing sometimes in the middle some times at the extremity
again I might have moved the quality slider to make this happen
Aldo

Aldo

Oshyan

Voxel Buffer computes cloud shape at a limited (user definable) resolution and limits cloud shading to that area, so it does sometimes miss smaller bits of cloud. You can increase voxel cache resolution, but this will of course increase render time. It may still be a time savings, so it's worth experimenting with.

I assume that you're using GI caching with all of this, certainly that's flicker stopper #1!

In any case provided the settings are the same, there should be no such unexplained differences between machines for render time. I think it would help troubleshoot if we knew 1: the specifications of the systems involved, 2: the location of your render files (i.e. on a central file store remote to all systems, on a folder on one machine that is also a render and then being shared to others, etc.), and 3: what the configuration of your network is.

- Oshyan

ragnoru

I am sorry but I went back to the previous release of TG, we are in production with a pretty tight deadline
so we just decide to revert back.
I manage to get most of my frames at 1600 by 900  (we are talking high altitude full frame clouds) to about
1 hour to 1h 1/2 a frame so I am pretty happy about that.

Putting optimization to "None" seemed to be the only way to avoid flicker of multiple altocumuls clouds intersecting.

Thank you for your help as soon as this craziness ends (the 20 something shots deliver soon)
I will see if I can provide all the information to help troubleshoot the problems I mentioned.

Thank you for the support.
Aldo