Render problems - TG2

Started by N-drju, February 09, 2014, 08:29:20 am

Previous topic - Next topic


I'm so sick of this!

I am trying to complete a render (detail 0.86, AA 3, res. 1400x1050) but instead of happy ending I get many squares of the final pic blacked-out and get 10 (yes, TEN  :o) errors, like so:


I don't know. Am I asking too much?

The scene is generally nothing special, except there are many populations. One is especially big as it is hundreds of thousands of grass patches. I tried to modify settings, crop region and so forth. Nothing helps. Once I waited almost 40 minutes for the grass patches to populate and after that... TG2 crashed...  >:(

Any help in solving this annoying problem will be greatly appreciated!
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"


Looks like a memory issue. Do you have enough memory in your machine to handle all the grass? What happens if you open task manager and look at the memory used, when loading and starting the render? You may have to change size of subdivision cache in advanced render settings.


You mean reducing the subdiv cache? That helped but instead I got warning that the memory per thread is low (something like that) and that it might affect performance.

As far as memory usage is concerned I'm not sure but I remember it was around 1.19GB (must check.) I have a pretty strong machine that generally works like a dream so I don't really believe it's too much for her. I removed all grass objects and instead used planetary grass shader by Martin - no success.

The render does fine with following settings - AA cranked down to 3 (:'(), bucket size 64x64, subdiv cache at about 320 and threads to 1-16. Fortunately detail is still at 0.863 with res of 1280x768...

Though it works I still get nightmares at bedtime, knowing that the problem is still somewhere there. In case you have any other ideas, I invite you to share.  :(
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"


Dune is right, it absolutely sounds like a memory issue and I would really be surprised if the scene and render settings you described were only using 1.2GB of memory. So first of all, what are your *full* computer specs? Especially CPU, Memory, Operating System. Second, please try rendering again with the original settings and watch Task Manager (or the OS X equivalent) for memory use and let us know what it says.

- Oshyan