Mars MOLA Map Shader Crash with 64/128ppd

Started by cdrose, April 09, 2014, 04:17:32 pm

Previous topic - Next topic

cdrose

Hi,

I'm clicking add terrain and then choosing "Displacement Shader" and then "MOLA map shader". I can load the 4/16/32ppd Mars MOLA files successfully but as soon as I try to load the 64/128ppd files the application just completely freezes on me  :-[

Can anyone help me? I've downloaded all required files for each set and are all contained in their own folders. I have an Intel i7-3930k and 32GB RAM.

Thanks,
Chris

Oshyan

Does Terragen actually crash, or just "freeze"? How long have you waited? It might take a little while for the 128 data to load as it's a fairly large and detailed data set.

- Oshyan

cdrose

April 15, 2014, 05:59:46 am #2 Last Edit: April 15, 2014, 07:17:42 am by cdrose
Quote from: Oshyan on April 14, 2014, 09:22:49 pm
Does Terragen actually crash, or just "freeze"? How long have you waited? It might take a little while for the 128 data to load as it's a fairly large and detailed data set.

- Oshyan


Hey Oshyan,
Yea I figured that might be the case and have waited for 5 minutes or more with the application not responding. I might give it another go and transfer the files to my SSD to improve the speed and see how that works. Can anyone else tell me how long their systems to take to load these files?

Thanks

UPDATE: I copied the 64 and 128 data files to my SSD and it appears to be working fine  :D thanks for the sparking the idea Oshyan and thank you OCZ for their RevoDrive3 X2's!!!!

Oshyan

Ah, glad to hear that's resolved it. Where was the data previously? On a regular hard drive it should not be so bad, but if it's over a network connection - even gigabit - it would likely be a bit slow.

- Oshyan

cdrose

Quote from: Oshyan on April 15, 2014, 11:57:37 pm
Ah, glad to hear that's resolved it. Where was the data previously? On a regular hard drive it should not be so bad, but if it's over a network connection - even gigabit - it would likely be a bit slow.

- Oshyan


They were on a Striped RAID (Windows 7) setup of 2 300GB HDD's so it should of been fine, maybe it was some fault or error occuring. The HDD's are WD VelociRaptor 300GB 10,000 RPM 16MB Cache SATA 3.0Gb/s.

Oshyan

Surprising, but again I'm glad it's working now. The MOLA shader is actually quite old; the data hasn't change since then, but I do wonder sometimes if there may be possible improvements to the data loading/handling. Something to think about for the future...

- Oshyan

cdrose

Quote from: Oshyan on April 16, 2014, 04:07:46 pm
Surprising, but again I'm glad it's working now. The MOLA shader is actually quite old; the data hasn't change since then, but I do wonder sometimes if there may be possible improvements to the data loading/handling. Something to think about for the future...

- Oshyan


Yea thanks for the help. Oh ok that would be good. It would be good to be able to map the HiRISE data to the planet too but at the moment I'm using standard base colour shader. I have the Mars Digital Image Colour Mosaic jp2 but can't get that imported, I tried converting the jp2 to something like tiff but the file is too large to save. So I'm just trying to simulate the colours at the moment. Is there a tutorial to show how to combine base colour with say a tileable texture?

Thanks,
Chris

Kadri


Chris can you give the link for the jp2 image file you try to use?
Nothing for sure but i have a basic thing-experiment in my mind and want to try if it works or not.

Oshyan

Are you using Terragen 3.1? The latest version may have support for the .jp2 data...

- Oshyan

cdrose

April 21, 2014, 05:50:10 pm #9 Last Edit: April 21, 2014, 05:55:11 pm by cdrose
Quote from: Kadri on April 18, 2014, 06:54:07 am

Chris can you give the link for the jp2 image file you try to use?
Nothing for sure but i have a basic thing-experiment in my mind and want to try if it works or not.


I can't remeber where I got it now, was off one of the NASA sites, it's called "MDIM21_AMES_recolor_dd0_ly.jp2" it's a colour Mosaic image, problem is it has lighting information in. Would be good to have HiRISE images compiled together to create one mega resolution map. I did find this ".cub" file though weighing in at 12GB!

http://astropedia.astrogeology.usgs.gov/downloadBig/Mars/Viking/MDIM21/Mars_Viking_MDIM21_ClrMosaic_global_232m.cub

UPDATE: I found the link: ftp://pdsimage2.wr.usgs.gov/pub/pigpen/mars/viking/mdim21_color_byAMES/MDIM21_AMES_recolor_dd0_ly.jp2

There's more dataset links here: https://isis.astrogeology.usgs.gov/IsisSupport/index.php?topic=1166.0

Quote from: Oshyan on April 20, 2014, 02:41:33 am
Are you using Terragen 3.1? The latest version may have support for the .jp2 data...

- Oshyan


I think so, the installer is the trial one, Terragen3-Win64-31020.exe.