Populator

Started by choronr, June 01, 2014, 11:57:08 pm

Previous topic - Next topic

choronr

June 01, 2014, 11:57:08 pm Last Edit: June 01, 2014, 11:59:54 pm by choronr
Question: I am populating on an object. I need to bring up the population using Populator 4. Instead, Populator 3 comes up. How do I do this? Thanks in advance for your help.

Oshyan

Populator 4 always comes up in Terragen 3 unless you are using a populator from an old project or old clip file. If the latter is the case, upgrade it to v4 with the gear button on the Object layout node list, then re-save the project/clip and only use that in the future.

- Oshyan

choronr

June 02, 2014, 07:19:44 pm #2 Last Edit: June 02, 2014, 08:27:18 pm by Oshyan
Quote from: Oshyan on June 02, 2014, 05:35:53 pm
Populator 4 always comes up in Terragen 3 unless you are using a populator from an old project or old clip file. If the latter is the case, upgrade it to v4 with the gear button on the Object layout node list, then re-save the project/clip and only use that in the future.


Thank you so much Oshyan. I guess this would also apply to the 'Sphere' object whereas the older version only had an output; and, the newer version has both an input and an output.


Oshyan

Hmm, no Bob, there's no difference like that. The Sphere still only has an Output by default. Inputs sometimes show up when there is a connection to an internal node parameter from an external node, such as the Surface Shader. But this is completely different than the Populator v3/v4 difference.

- Oshyan

choronr

The reason I brought it up Oshyan is that I was experimenting with someones .tgd file and tried to replicate it with some modifications. When I bring up the Sphere, it has only an output. I guess my question then would be, how would one bring up a Sphere object with both an input and an output if you needed it?

Oshyan

Yeah, it doesn't work that way, some inputs are dynamically shown/hidden. I'm not sure why this is frankly. But the way to do it currently is just to go into the Sphere (for example) and go to the Shaders tab and select your Shader node there with the little + button on the right of the field.

- Oshyan

choronr

Quote from: Oshyan on June 02, 2014, 09:40:10 pm
Yeah, it doesn't work that way, some inputs are dynamically shown/hidden. I'm not sure why this is frankly. But the way to do it currently is just to go into the Sphere (for example) and go to the Shaders tab and select your Shader node there with the little + button on the right of the field.

- Oshyan

Thanks for this Oshyan, just needed to know more about how the input/output version is attained. Your explanation makes it clear.