Vortex warp shader problem

Started by Kadri, January 29, 2015, 09:06:17 am

Previous topic - Next topic

Kadri


Does have anyone tried the Vortex warp shader on a second planet?
I tried to place it for the clouds and then for the ground but could not get it to work.

Then i used a default second planet as it is without changing size and place. It worked in this scene.

I suspect the big different center numbers might be the problem (the planet is far away from zero point for example).
But things like local clouds or image maps do work as they should.



Dune

Quickly testing; works alright.

Kadri


Yes you are right Ulco.I tried it with another default scene and it worked.
But the scene in that i need it, it is stubbornly not working :D

I am still working on it. I changed the extreme values to more reasonable numbers but still no luck.
Might have to do with some other nodes too. Will see.

Kadri

January 29, 2015, 02:22:22 pm #3 Last Edit: January 29, 2015, 02:27:58 pm by Kadri

I think i found the problem.

I had a "transform input shader before the vortex shader.
The vortex shader was the last node in the chain and i thought that it should show up.
But when in the transform shader "Use world space(final position)"  is enabled  the vortex shader doesn't show up.

Transform input and Transform merge shaders behave in the same way.

I don't remember why i had that option enabled but this behavior looks unintuitive to me. 

Matt

All of Terragen's warp shaders work by warping texture coordinates. "Use world space" replaces the texture coordinates with world space coordinates, so the warp effect is lost.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Kadri


Thanks Matt. Good to know. Feels like WYSIWYG is lost :)