Deleting numbers after the period crashes Terragen

Started by Kadri, July 14, 2015, 11:16:20 AM

Previous topic - Next topic


I have a scene that uses  10 000 x 10 000 big image files for clouds.

When i try to change the first digit for the size of the image after the period Terragen crashes.
But only when i delete that digit or use backspace.
Deleting other digits after that first digit at the right of the period doesn't crash Terragen.

Selecting the digit and then typing directly a new number doesn't crash Terragen.

If there is only one digit and you try to delete it that gets a crash too.

But it looks like it is related to the 3D preview window.
When it is paused or not updating (other tabs selected like Terrain for example) it doesn't crash.

I tried it with a small image file and it didn't crash.

There might be other possibilities too but these were what i tried and it was repeatable.
Not sure if it is graphics card-driver related.
I remember vaguely that similar things were around but wasn't sure and hopefully this helps if it is still present or a new problem.

Selecting and directly typing a number without deleting first is an easy workaround.

It is with Terragen and Windows 8.1.


Hi Kadri,

Does it crash when connected to the surface, or just the cloud layer?

Can you send us a copy of the shader node, and if possible the image file? Or another file that produces the same crash?

Just because milk is white doesn't mean that clouds are made of milk.


I will have a closer look and try to minimize the node configuration and to repeat the same crash.
It doesn't happen in all nodes.


Hi Matt,

I tried different things and minimized the file so much i can.
It happens with small files too.That is what i post here.

I tried to replicate the crash in a default scene but nothing happened.

It looks like you have to use a second planet or anything specific to this scene for this to happen.I don't know.

Changing the size of the image in the main image node doesn't crash Terragen.
The crash happens only when i change the size (not sure of other places) in the Mask node.
Kinda specific problem but still i hope it helps.


A crash occurs if the projection size becomes 0, and that's happening here (because your values were 0.45 and 0.6). I forgot to account for the division by zero.  :-[

I'm fixing this now so in the next update it won't be a problem.

Thanks for the report.

Just because milk is white doesn't mean that clouds are made of milk.