GI flicker once again...

Started by Hannes, September 03, 2015, 03:46:32 am

Previous topic - Next topic

Hannes

At the moment I'm doing an animation with lots of Star Wars storm troopers and a bright imperial ship hovering in the air.
The GI flicker in my test animations was tremendous! So I created a GI cache file. It's not flickering anymore, but it's more of a very obvious "GI-pumping" now.
I created the GI cache with GISD on. I remember it was said, that GISD isn't recommended for animations, but as far as I know it was because of higher rendering times. It was also said that the GI cache file(s) don't include GISD, so I did a test sequence of about 80 frames with GISD unchecked with the previously created GI cache file.
The pumping was still there, and render times were not much faster.

So, did I forget something, or did I get something wrong? Is there any way to get rid of that ugly pumping?
I have to say that the render quality may be a factor too. I'm using Detail/AA of 0.4/4 at the moment, which is not quite high, I know.

The GI cache file is calculated for each single frame (with the actual rendering quality settings), and for rendering I used blend mode "interpolate" with 6 files to blend.

Any suggestions?

Kadri


For animation i only render the frames i will need.
If i will use 5 frames blended i only render the 5'th frame for the GI cache.
Not sure but the only difference might be faster-shorter render times?

For some problematic scenes i got to AA 1/10 even.
I had a scene that was so bad even with high settings i used one frame of a separate render as a background instead the object itself.
But that was for flicker and the scene was appropriate for that kind of use.
Your problem looks a little different Hannes.

Maybe you have some parts outside the frame affecting the scene
and should use higher settings like in "Ray detail region padding" and-or GI prepass padding i don't know without seeing the scene.

Hannes

Thanks Kadri!
Yesterday I read somewhere that it's useful to render as much frames as possible (all of them so to speak  :)) for the GI cache file to get the smoothest result.
I'm not sure if a higher "Ray detail region padding" would solve it, but GI prepass padding sounds promising. I actually forgot about that, and I have to check that out.

I rendered in these quite low settings, because I want to do a 600 frames animation. Two scenes with 300 frames each. It's going to take some time, and I want to see some results!!! ;)

Tangled-Universe

Quote from: Hannes on September 03, 2015, 03:46:32 am
At the moment I'm doing an animation with lots of Star Wars storm troopers and a bright imperial ship hovering in the air.
The GI flicker in my test animations was tremendous! So I created a GI cache file. It's not flickering anymore, but it's more of a very obvious "GI-pumping" now.
I created the GI cache with GISD on. I remember it was said, that GISD isn't recommended for animations, but as far as I know it was because of higher rendering times. It was also said that the GI cache file(s) don't include GISD, so I did a test sequence of about 80 frames with GISD unchecked with the previously created GI cache file.
The pumping was still there, and render times were not much faster.

So, did I forget something, or did I get something wrong? Is there any way to get rid of that ugly pumping?
I have to say that the render quality may be a factor too. I'm using Detail/AA of 0.4/4 at the moment, which is not quite high, I know.

The GI cache file is calculated for each single frame (with the actual rendering quality settings), and for rendering I used blend mode "interpolate" with 6 files to blend.

Any suggestions?


GISD is also doing stuff at rendertime, so I wouldn't be surprised if it would also affect the GI prepass to some extent.
If it's recommended to disable it then I'd do that for the time being.

My suspicion is that the "GI pumping" is perhaps because you are caching each frame and only blend 6.
Normally you cache every ~4th frame or so and blend 6, resulting in blending of GI for 1 second of animation.
Now it's only blending a quarter of a second.

That does not necessarily mean the GI "pumps" at an interval of a quarter of a second, because the changes in GI are mostly due to changes in the scene due to camera speed, parallax etc. etc.

Kadri

Quote from: Hannes on September 03, 2015, 04:31:49 am
...
Yesterday I read somewhere that it's useful to render as much frames as possible (all of them so to speak  :)) for the GI cache file to get the smoothest result.
...


Do you remember the link Hannes?

Oshyan

We were unsure if GISD would be entirely "animation stable" but the good news is that it appears to be so, at least in all the tests I've done. So I don't think GISD is responsible for your problems.

GISD *does*, to my recollection, affect the GI cache as well, though that's only part of the effect. In general I'd recommend keeping it on until and unless you're sure it's causing issues.

Martin's suggestion is more along the lines of what I think will resolve the problem. I'm not sure where you read that the more GI cache frames you have the better - it's actually *somewhat* the opposite. The fewer frames you're blending, the smoother the result will generally be (within reason) because there's less variance between them. But you want to strike a balance between e.g. using just a single cache file for an entire animation (static GI, essentially, even if lighting changes) and using 1 for every frame (every frame's lighting changes are represented in GI, but it can create flickering).

So basically the recommendation is, as Martin said, to render every 4th or 5th frame or so, then blend between 3 and 5 frames. I would suggest starting by rendering a GI cache for every 5th frame. Then set it to Interpolate for Animation and blend 3 frames. If there is still flickering, try blending 5 frames. Note that the more frames you are blending, the bigger the render time and memory impact.

- Oshyan

Hannes

Well, that's weird, I don't remember where I read that or if I misunderstood something, but what the hell, I'll try your suggestions. The second part of my animation is done, but I'll try to improve it!
Thanks for your tips!!!!!

Hannes

OK, I just created a GI cache file (every fifth frame) in just ten minutes!! I'll do an overnight test animation with your suggestions, and I hope it will work!

Matt

The quality settings of your GI cache are also important. "GI sample quality" especially. The default of 2 is quite low and will generate a lot of flicker. Cache file blending will smooth it out, but try to reduce it at the source if possible.

Matt
Just because milk is white doesn't mean that clouds are made of milk.

Oshyan


Hannes

Thanks a lot, Matt and Oshyan!
I must have been drunk or whatever, believing that I had to create one cachefile per frame... :-[

OK, the overnight test was better, but still not good. I'm sure I had read the appropriate planetside wiki about GI cache files, but I seem to have forgotten it.
Getting old is no fun!! ;)

At the moment I'm creating a GI cache file (every fifth frame) with GI cache detail and Sample quality of 4/4.

Tangled-Universe

Quote from: Matt on September 03, 2015, 08:53:25 pm
The quality settings of your GI cache are also important. "GI sample quality" especially. The default of 2 is quite low and will generate a lot of flicker. Cache file blending will smooth it out, but try to reduce it at the source if possible.

Matt


As usual it depends on the situation which value works, but generally speaking, what value would you recommend to start with?

Hannes

Quote from: Hannes on September 04, 2015, 01:18:05 am
At the moment I'm creating a GI cache file (every fifth frame) with GI cache detail and Sample quality of 4/4.


I rendered 50 frames with the above settings and 4 files to blend, and the flicker is completely gone!!  :) :) :) :) :) :) :)

Thanks a lot!!!!!

Matt

Quote from: Tangled-Universe on September 04, 2015, 07:45:50 am
As usual it depends on the situation which value works, but generally speaking, what value would you recommend to start with?


I prefer GI sample quality between 4 and 8, but over the years I have heard many users say that 2 is sufficient for stills (e.g. 4/2). But animations really show just how inaccurate 2 is when you see the amount of variance between frames. Low values can be smoothed out by blending lots of cache files, especially if rendered sparsely e.g. every 5th or 10th frame, but higher GI sample quality also gives you a more accurate result, so I prefer to go higher.

Matt
Just because milk is white doesn't mean that clouds are made of milk.