Cubemap Seams

Started by Leadwerks, September 23, 2015, 09:55:54 PM

Previous topic - Next topic


I'm using Terragen 3 to render some skybox cubemaps and I have noticed there are sometimes seams in the image.  You can see here the bottom image is noticeably darker than the sides, and it is quite apparent in-game.

Is there a way to eliminate these seams?  I have all the settings identical in all renders.


This is caused by global illumination being calculated slightly differently for each frame. The GI is calculated as a pre-pass for each frame. Different views can cause slightly different results, and there's also a random element which can make subsequent renders different even if the view doesn't change.

To solve this you need to create a GI cache file (s), and have each frame read the same cache file(s). The best solution depends on whether you have Terragen 3 Professional or Terragen 3 Creative.

Terragen 3 Professional (using spherical camera mode):

1) Set the camera projection mode to Spherical, with rotation 0,0,0.
2) In GI settings, tell it to write to a GI cache file.
3) Render an image, so that a GI cache file is generated.
4) In GI settings, tell it to read the GI cache file you previously generated.
5) Render your skybox images.

Terragen 3 Creative (does not have spherical camera mode):

1) In GI settings, tell it to write to a GI cache file, including "%04d" somewhere in the filename (not including quotes).
2) Render your 6 skybox images. Each frame will generate a GI cache file to disk, instead of rendering a final image. It should generate 6 files.
3) In GI settings, tell it to read one of GI cache file you previously generated (and one in the sequence will do). Set the blend mode to "Equal Blend Within Range" and set the "number of files to read" to 6. The idea is to make sure that whatever you render from now on, it will read all 6 caches and combine the result.
4) Render your skybox images.

For more info:


Just because milk is white doesn't mean that clouds are made of milk.


I do not see any setting to set a cache file in the renderer GI settings.


Seems you have a version without the GI cache feature. I wasn't aware there are such versions.


Indeed, the Creative version without animation does lack GI Caching features. This is largely because in order to make good use of GI caches you need to be able to use animation-specific features like file sequences (even in non-animation tasks like skybox rendering) since a primary benefit of caching is to be able to blend multiple cache files together.

So to resolve this you can either upgrade to Creative + Animation (just the difference in cost between the versions), or avoid using GI.

- Oshyan