tgd suddenly crashes Terragen 4.1.18

Started by KlausK, April 17, 2018, 02:49:41 am

Previous topic - Next topic

KlausK

April 17, 2018, 02:49:41 am Last Edit: April 17, 2018, 03:10:29 am by KlausK
Hello everyone

The attached scene suddenly crashes TG. Hit "Render" and it starts doing its thing.
When the first pass is done (the one where you see the little coloured dots) it should start the final pass but Terragen disappears and I get a error popup.
Worked normally to one point. I am on Win7Ult..
To my eyes there is nothing unusual in the settings. But I am curious to find out what is going on. Maybe another pair of eyes sees what I am missing...
Anybody willing to open it and hit the render button, please?
Thanks!
CHeers, Klaus

ps: the scene works when you disconnect the "Merge Shader" side of nodes and feed the "Surface Layer" directly into the "Compute".
Feeding another node into the "Input" of the "Merge Shader" does not help. And the 3D Preview window renders just fine...with and without RTP.
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate


Hannes

Confirmed. And Kadri is right. Disabling the Fake stones shader makes the render work. Sounds weird... ???

Kadri


With Stone talness "5" the render finishes.
But with "10" it renders on and on with just 1 tile remaining(but dosn't crashed).

jaf

Weird. The first time I tried the render, I checked "Lock aspect ratio" and set the width to 700 (from 1400).  It rendered fine.  I set the width back to 1400 and it crashed during render.  Tried the same process again with the same results.

Just loaded and rendered and it crashed.  Changed the height from 450 to 550 with the width left at 1400 and it crashed without getting to the second phase of the render (all dots).

Tried several more renders at different size/aspect ratios, but only had successful renders @ 700x225.   :o

(19oct19) Ryzen 1800x, 970 EVO 1TB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 436.48 (02oct19), Win 10 Pro x64, Terragen Frontier 4.4.39 BMark 0:10:18

Kadri


Yes with lower resolution it rendered in my test too.
Interesting problematic scene. Trying to end task with task manager didn't work too.

Kadri


The "Render subdiv settings" are not at default. I changed the Render node with a default one only and it rendered fine.
Without changing the fake stones etc. Weird!

jaf

Good catch! Looks like the subdivision "Force all edges" is the culprit.  Unchecked, it renders fine.
(19oct19) Ryzen 1800x, 970 EVO 1TB NVME-M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 436.48 (02oct19), Win 10 Pro x64, Terragen Frontier 4.4.39 BMark 0:10:18

KlausK

April 17, 2018, 05:19:04 pm #8 Last Edit: April 17, 2018, 05:20:41 pm by KlausK
Thanks all who were looking into this!
The "Force all edges" was there before the "Fake Stones", I remember. I did not disable the setting because I forgot about it.
But who would have thought it would not play well together with the "Fake Stones Shader"...

Maybe it is something you guys at planetside want to look into sometime.

Anyways, now off todisable this settingg before I forget again ???
CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate