Animated clouds that flicker in the tgCloudDirect pass only.

Started by DutchDimension, August 17, 2018, 05:00:30 am

Previous topic - Next topic

DutchDimension

August 17, 2018, 05:00:30 am Last Edit: August 17, 2018, 05:05:46 am by DutchDimension
So I've got three Easy cloud systems at various altitudes. The atmosphere is very dense and I've animated the Growth parameter to rapidly shrink the thick, heavy clouds. The sunlight comes streaming through it.
Plenty of GI cached frames which I'm interpolating resulting in a very clean looking 'tgCloudIndirect' pass. However, my 'tgCloudDirect' pass is showing significant flickering in the larger shadow masses of the clouds closest to the sun. Despite having pretty strong quality levels. AA6, Micropoly detail 0.1 (no terrain is visible, so I suppose it can be this low?), Ray marching quality at 0.8, Cloud GI quality at 'Sequence Quality x4', Cloud GI max ray depth 2, Voxel scattering quality 50. Pixel noise, while visible is acceptable and not the issue here. Flickering only really starts once the growth parameter starts decreasing. I'm thinking shadows are the culprit? Any suggestions? Testing disabling 'Use voxels for shadows' now. Fingers crossed.

ajcgi

I had flickering GI for the first time in a very long time this week. Had to blend 20 files in the end to fix it. Are you blending over a large amount of frames?

DutchDimension

Thank you for replying, I'm blending across 5 frames. But I don't think this is where the problem lies, because the tgCloudIndirect pass is pretty clean and does not exhibit any flickering. It can however be clearly noticed in the tgCloudDirect pass.
I put a full frame render on the farm over the weekend with the 'Use voxels for shadows' disabled. Lets see what the results are on Monday.


Oshyan

Interesting. As noted in another thread, the GI cache does not currently support caching of v3 cloud GI. So you may need to increase beyond Sequence x4 unfortunately. However, I don't know, but disabling the voxel shadows *may* help. I'll see if Matt can weigh-in here, he's more likely to have a good idea how to address this, given the specifics of the issue.

- Oshyan

DutchDimension

Thanks Oshyan. My 208 frame weekend render completed. It appears that disabling 'Use Voxel Shadows' has gotten rid of the shadow flickering. Now I just got to try and further optimize the scene.

I have potentially a lot of skies to render for the sequence I'm working on. So on that note, I sent you guys an email about commercial render license pricing, but haven't received a reply yet. Would love to get a quote to pass on to my boss. :D

ajcgi

Quote from: DutchDimension on August 20, 2018, 02:14:36 am
Thanks Oshyan. My 208 frame weekend render completed. It appears that disabling 'Use Voxel Shadows' has gotten rid of the shadow flickering. Now I just got to try and further optimize the scene.

I have potentially a lot of skies to render for the sequence I'm working on. So on that note, I sent you guys an email about commercial render license pricing, but haven't received a reply yet. Would love to get a quote to pass on to my boss. :D


Ah I see what you mean now. I had that not so long ago on a flipping long shot. The shadows buzzed like hell and turning that off was the only thing that helped.