Crash With Small Values in Smallest Scale (Repeateble)

Started by Cyber-Angel, October 15, 2007, 08:09:45 pm

Previous topic - Next topic

Cyber-Angel

I have found some thing that may or may not be known if you are working with the power fractal (Haven't tested this with the Alpine Fractal yet) and you set both the Lead-in Scale and the Smallest Scale Sliders to small values (Almost all the way to the left) you get a Screen (See Provided Screen Shoot) telling you that TG2 has encountered an error and need to quite.

Regards to you

Cyber-Angel 

Oshyan

I can't reproduce this using the information provided. Was there a specific sequence you made your adjustments in (e.g. Smallest Scale first)? What version are you running?

- Oshyan

Cyber-Angel

Hi Oshyan.

I am using the latest version "Build 1.9.04.1" in reference to your query on the specific sequence: I adjust the Lead-In Scale First then Smallest Scale.

I've included a screen-shoot of the open error message! Basic but it might help.

Regards to you

Cyber-Angel       

Oshyan

That appears to be a graphics driver issue and thus not likely a TG2 problem per se. What graphics card do you have and are you running the latest drivers?

- Oshyan

Cyber-Angel

I have a RADEON 90200 Pro card and the drivers are up to date.

Regards to you.

Cyber-Angel

Oshyan

The only other thing I could suggest would be to turn down graphics card acceleration functions. I know that the more recent ATI drivers have been causing some OpenGL problems though (see this thread: http://forums.planetside.co.uk/index.php?topic=2016.msg20716#msg20716 ) so it may just be that.

- Oshyan

Cyber-Angel

I have just tried your suggestion as an experiment I tried all Acceleration Settings bellow full one at a time using the same procedure as previously described including  turning of acceleration altogether each time I go the same error and TG2 quite on me, I am now out of ideas but it appears that it only accrues with the smallest values I.E. with the sliders almost all the way to the left.

Regards to you.

Cyber-Angel         

jaf

I was going through the user contributed tutorials (Surfacing, Objects, Populations) and ran into this problem.  And yes, I realize the tutorial is rather dated, but new user's are going to run that tutorial and then start searching the site for "lines in clouds" and probably not get to this post and start a new round of questions on the subject.

I'm using v2.0 (build 2.0.3.1) and it's very easy to see.  Just add the Power fractal shader v3 and small scale values and there are either render error messages ("An unknown error occurred in trBucketRenderMore() rasterised pass") or vertical lines appear in the atmosphere.  The tutorial uses Feature scale = 0.01, Lead-in scale = 0.1, and Smallest scale = 0.001.

It seems Smallest scale values of less than .003 (and leaving the other scales at the default) will initiate problems.

[edit] One of the reasons I bring this up is obviously one could enter a .001 in smallest scale and not get the errors I see now, when that tutorial was written.  I would suggest the application limit the smallest value if it can't be fixed in the power fractal shader code.

Oshyan wrote: "I can't reproduce this using the information provided. Was there a specific sequence you made your adjustments in (e.g. Smallest Scale first)?"

All I have to do to see the problem is start tg2, add the power fractal shader, and set the smallest scale to .001 and watch the preview window.
(03Jul2020) Ryzen 1800x, 970 EVO 1TB M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 451.48 (24Jun2020), Win 10 Pro x64, Terragen Pro 4.5.38 Frontier, BenchMark 0:10:02

Seth


jaf

Then the author of the tutorial doctored his images in the tutorial pdf.  ;D
Oh, and .002 doesn't work either.
(03Jul2020) Ryzen 1800x, 970 EVO 1TB M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 451.48 (24Jun2020), Win 10 Pro x64, Terragen Pro 4.5.38 Frontier, BenchMark 0:10:02

Seth

didn't he corrected with something like 0.00125 ? i thought he did but if 0.002 crashed too...

jaf

No, it's still .001 in the standalone pdf and the zipped version included with the objects.
(03Jul2020) Ryzen 1800x, 970 EVO 1TB M.2 SSD, Corsair Vengeance 64GB DDR4 3200 Mem,  EVGA GeForce GTX 1080 Ti FTW3 Graphics 451.48 (24Jun2020), Win 10 Pro x64, Terragen Pro 4.5.38 Frontier, BenchMark 0:10:02