Author Topic: TG4, buckets rendering in varying colors (only happens to objects)  (Read 155 times)

Offline Shigawire

  • Member
  • *
  • Posts: 62
I am working on a scene with some rocks in it. I added the rocks made by Jordan Thompson, as a population of very large but few rocks. A part of a sedimentary glacial deposit from the flow map of an Erosion shader.

Link to Jordan Thompson's beautiful rock :)
https://planetside.co.uk/forums/index.php/topic,24690.msg251102.html#msg251102

And when I render them, this attached image is the result.

I know that it's likely due to GI settings, and RAM usage. I only have 32 gb of ram, so maybe that's the problem?
And even if I don't have the most RAM in the world, I wouldn't mind waiting a little longer if the renderer just made sure to not do this.

Any thoughts and suggestions?

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12873
  • Holy snagging ducks!
Re: TG4, buckets rendering in varying colors (only happens to objects)
« Reply #1 on: January 10, 2019, 11:14:23 PM »
This is very unusual. Are you using that specific Granite shader of his? Can you provide the TGD you've integrated it into?

- Oshyan

Offline Shigawire

  • Member
  • *
  • Posts: 62
Re: TG4, buckets rendering in varying colors (only happens to objects)
« Reply #2 on: January 10, 2019, 11:35:55 PM »
Sure thing. Here's the TGD.

Something to be aware of: Daniil's Erosion shader for some reason doesn't load the erosion data file upon loading the project.
I've reported this to him in the appropriate thread.

To repeat the effect, upon loading you have to:

1.Make sure you have Daniil's latest Erosion plugin (but you're Oshyan, of course you do ;) )
2.Click the Erosion shader (Daniil Kamperov::Classic Erosion 01)
3.Erode & wait
4.Click "Pop Rock 01"
5.Populate now & wait
6.Render & wait

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12873
  • Holy snagging ducks!
Re: TG4, buckets rendering in varying colors (only happens to objects)
« Reply #3 on: January 11, 2019, 10:04:22 PM »
I would say this rock setup is built a bit strangely and can be problematic, as in this case (I don't know if the original is like this). You can fix the result either by changing the render method (Rendering tab of the rock object) to Force Displacement, or by switching from Front Projection to Spherical in the Stone Colour Map. I personally tend to avoid front projection for textures like this as it can create some strange and unwanted effects and generally looks more unrealistic.

- Oshyan

Offline Shigawire

  • Member
  • *
  • Posts: 62
Re: TG4, buckets rendering in varying colors (only happens to objects)
« Reply #4 on: January 12, 2019, 12:27:36 AM »
I didn't change a thing on the rocks, but I figured it was something to do with the rocks somehow. I'm still quite a noob.
Thank you very much for your tips sir. I'll try my hand at these suggestions.

Offline Shigawire

  • Member
  • *
  • Posts: 62
Re: TG4, buckets rendering in varying colors (only happens to objects)
« Reply #5 on: January 12, 2019, 01:49:29 AM »
That worked wonders! Again, thanks a lot for rendering excellent service. Maybe that even helped with some of the crashes I've had.

Offline Oshyan

  • Planetside Staff
  • *
  • Posts: 12873
  • Holy snagging ducks!
Re: TG4, buckets rendering in varying colors (only happens to objects)
« Reply #6 on: January 12, 2019, 11:47:49 PM »
You're welcome. :)

- Oshyan

 

anything