New forum version and theme - updates ongoing

Started by Oshyan, August 03, 2019, 07:18:00 pm

Previous topic - Next topic

Oshyan

August 03, 2019, 07:18:00 pm Last Edit: August 15, 2019, 02:02:10 am by Oshyan
Hi all! You've probably noticed that the look and functionality of the forums has changed quite a bit since your last visit. You're not going crazy, we've updated to a new version of our forum software, and a new theme.

Note: this post has been updated following the addition of a new light and dark theme option.

We've been waiting on the forum software development team to add useful new features like @mentions, likes, etc. and while this version isn't yet finalized, we decided to upgrade early to get access to all that great functionality. So, welcome to the future! ;D

You can find more info about new features and functions (some cool ones!), including a new Light and Dark theme option here:
https://planetside.co.uk/forums/index.php/topic,26784.0.html

Currently the forum is running in a "vanilla" mode, which means all old plugins such as enhanced search, YouTube and Vimeo embed, etc. are disabled. We'll be adding things back in slowly as we determine what is still needed, as the new SMF version actually includes some of the features we used to rely on plugins for.

The theme is also not yet customized for our look and layout preferences. Expect it to change and improve over time. But on the bright side it is now *responsive* and should look and work a lot better on mobile.

So explore the new options, "Like" a post, @mention someone, have fun, and let us know if you encounter major issues! Just remember may be a work in progress a little longer. ;)

Known issues: Looks like some of you lost your avatars in the upgrade. Not sure why, but hopefully you can re-upload them. On the bright side max avatar size is now 100x100px instead of the old, tiny 65x65. :D

- Oshyan

DannyG


Oshyan

August 03, 2019, 08:59:31 pm #2 Last Edit: August 03, 2019, 11:05:33 pm by Oshyan
Quote from: DannyG on August 03, 2019, 08:57:59 pmAwesome, Looks great guys !
Thanks @DannyG ! I'm especially liking the new quote functionality. Will hopefully make it easier for people to use well. :)

- Oshyan

WAS

August 03, 2019, 10:04:30 pm #3 Last Edit: August 03, 2019, 10:48:44 pm by WASasquatch
New theme looks alright. Glad you upgraded, page actually loads faster FYI so must be some nice improvements to SMF. If ya'll don't change the theme, it'd be cool if the orange accent theme was changed to something that matches Planetside.

Also, for the love of all that is sane, please please please make that post top-padding/margin for the HR larger. It's so odd having the line right up against the end of posts. The top-padding/margin for the like button seems like an appropriate spacing.

Also the quick edit is broken. Loads a blank post into the full editor when you save.

You also cannot upload attachments through the quoting or quick reply, which is way too common here.

Now that we are on 2.1, maybe we could install a Chat module [for members]. Might be fun? Could help with quick questions too that may not otherwise need a topic.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Oshyan

Quick Edit and Quick Reply both work here.

You never could use attachments through Quick Reply. It's just functionality that never existed in SMF. You have to do Preview and then you can add them. The alternative is just to have no Quick Reply.

- Oshyan

WAS

August 03, 2019, 11:21:00 pm #5 Last Edit: August 03, 2019, 11:28:03 pm by WASasquatch
Quote from: Oshyan on August 03, 2019, 11:09:28 pmQuick Edit and Quick Reply both work here.

You never could use attachments through Quick Reply. It's just functionality that never existed in SMF. You have to do Preview and then you can add them. The alternative is just to have no Quick Reply.

- Oshyan

Lol yeah, it works now. Something was fixed.

And, I know this, that's not what I mean. I'm talking about the nature of the forums here at Planetside and always attaching images for replies on support/help/conversations not to mention file shares/help.

And now there is no quote reply button to quote normally to upload an attachment that way. You have to quote, copy, than reply normally and paste.

Also, it may have always been that way for vanilla, but it can be modified. I believe it even has a global class so may be able to copypasta the attachment editor. Which, since it's a dropdown upload/editor should fit nicely with the quick reply. The edit functionality may not work though with this dynamic uploader and may actually need real editing.

Scratch that on the last part. Since it's a quick reply and never edits post it wouldn't be a problem.

Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Dune

Sorry, but I liked the old forum display way better. I had a direct link to login in my browser, and  I miss the top link to view all new posts at once. Also, I think the letters (and smileys and such) are smaller and harder to read. Only the middle part of the screen is used. I'm afraid I have to get used to this  :(

archonforest

Ohh God what happened here? Everything is white, no contrast... can we have an option to change this?
Dell T5500 with Dual Hexa Xeon CPU 3Ghz, 32Gb ram
Amiga 1200 8Mb ram, 8Gb ssd

Hannes

Quote from: Dune on August 04, 2019, 01:48:58 amSorry, but I liked the old forum display way better. I had a direct link to login in my browser, and  I miss the top link to view all new posts at once. Also, I think the letters (and smileys and such) are smaller and harder to read. Only the middle part of the screen is used. I'm afraid I have to get used to this  :(

Oh yes, I agree. Especially the top link that Ulco mentioned.

Dune

I found that link in the meantime; top right (unread posts and updated topics). But a bit bigger screen use and stronger lettering would be great. Like when you write your reply.

I do like the ability to insert more images in one go, though.

KlausK

August 04, 2019, 05:59:08 am #10 Last Edit: August 04, 2019, 06:00:54 am by KlausK
Well, I am an Old Fart, I guess. I do not like change very much - especially when it does - again - like in so many places only benefit the thumb-scrolling-writing folks it seems.

Work in Progress:

- why do the descriptions of the forum sections take up so much more space than the field for the "Last Post"?
They get truncated which hinders a quick overview on opening the front page.
- the theme colours are much too bright.
- contrast too low.
- it should hopefully be possible to let me choose a dark theme later on.
- what I see on my 27" monitor is way to thin lettering - so now I am forced to use ctrl-+ to zoom in and ctrl-0 to get back to my medium default zoom level.
- a waste of screen space. But that is because of the so called "responsive" design features I presume.
- please, get rid of the stupid confirmation messages like "Do you really want to mark all messages read?"! This is and has always been...
- "Like" buttons disappear more and more from websites and this forum introduces them...I don`t get it.

This is my first impression. I know it is not fair, it is unreasonable and for sure I will have forgotten all these things in a while, but anyways.
For me webdesign went backwards with the take over of mobile phones and thumb-scrolling.

More and more I find what I find comfortable to use is less and less reflected in what I find in the (Internet) world. But that`s because I am an Old Fart and sit at home at a COMPUTER (:)!)

- ON THE PlUS SIDE (for now): the forum loads faster.
(But that might be because it runs without any plugins)

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate

Dune

In responsive I'd expect the full window size to be used, not just 2/3. It indeed takes getting used to (I don't like changes either), but some things need change.

cyphyr

I like the new look, not blown over by "likes" or "emotecons" but each to their own so no problemo.

I would like to see thumbnail previews of images in posts.
It would make the images forum very much more interesting.
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

Dune


cyphyr

Not seeing them , do they have to be enabled somehow?
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)