New forum version and theme - updates ongoing

Started by Oshyan, August 03, 2019, 07:18:00 pm

Previous topic - Next topic

WAS

August 12, 2019, 12:56:29 pm #45 Last Edit: August 12, 2019, 04:04:31 pm by WASasquatch
Quote from: cyphyr on August 12, 2019, 06:30:03 amI'm having problems posting anything that has a link in FireFox.

I keep getting a pop-up:

CleanTalk:***Forbidden. Please enable JavaScript.***

Then when I go to post again after removing any links I am told I have already posted only to find that there is nothing there.

Can't seem to find any reference to JavaScript in my current version of FireFox.
I thought JavaScrit was pretty much superseded.
And I have just checked and it is enabled :(

CleanTalk.JPG

I noticed this same thing already posting another bug on SMF main website themselves getting some support on something. It took me twice to post a topic, few times to post a reply to said topic. Their security measures for posts is buggy.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Oshyan

Was it the same error? CleanTalk is not part of SMF by default. I'd be curious to know if SMF is officially using it on their own forums.

- Oshyan

WAS

Quote from: Oshyan on August 12, 2019, 01:05:59 pmWas it the same error? CleanTalk is not part of SMF by default. I'd be curious to know if SMF is officially using it on their own forums.

- Oshyan

Yeah, same error about post already made. Going back would produce this error, I had to go back to main topic/board and hit reply/new thread.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Oshyan

Ah, that's one of the errors he got, but not the one about CleanTalk. In the case of "post already made", sometimes refreshing the page will fix that. It happened occasionally on the old forums too.

- Oshyan

WAS

August 12, 2019, 06:19:36 pm #49 Last Edit: August 12, 2019, 06:22:03 pm by WASasquatch
Quote from: Oshyan on August 12, 2019, 04:22:55 pmAh, that's one of the errors he got, but not the one about CleanTalk. In the case of "post already made", sometimes refreshing the page will fix that. It happened occasionally on the old forums too.

- Oshyan

Specifically, refreshing, or going back, wouldn't let me do it. I had to go back to the board/topic and hit the button all over to start a form. I think regardless of CleanTalk they are sending form tokens. As these days, you can mask where a request is coming from to make it seem like it's the server doing it so domain checking doesn't work anymore, or at least shouldn't be relied on. For example, if I changed my host file to mask my localhost as a domain name "planetside.co.uk" or w/e, the request headers will show that domain so the actual server using that TLD will think it's from itself.

So I think the token is somehow being saved (draft system) and thus acting like it's been posted.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Oshyan

Good news everyone! With help from @WASasquatch we've now got nice, customized Light and Dark theme options for you! Head on over to the new features post for more info and instructions on how to switch.

https://planetside.co.uk/forums/index.php/topic,26784.0.html

P.S. CleanTalk is also now uninstalled. Let's see how the spam goes...

- Oshyan

cyphyr

Like the new theme, thank you all :)
Don't like that it extends right across my wide-screen monitor, prefer full screen with large left and right padding. but that is a small gripe.

So CleanTalk is an anti spam filter ... hmm might want to put that back then, but I guess we'll see. We have been blessedly spam free for the most part. Of course the ability to post links is necessary so a conundrum indeed.

Cheers
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

digitalguru

August 15, 2019, 06:21:02 am #52 Last Edit: August 15, 2019, 06:32:43 am by digitalguru
I really like it now (the dark theme) , better than the original I think.

Quote from: cyphyr on August 15, 2019, 05:01:27 amDon't like that it extends right across my wide-screen monitor
Agreed at first glance, but ultimately better for posting images.

WAS

Quote from: cyphyr on August 15, 2019, 05:01:27 amLike the new theme, thank you all :)
Don't like that it extends right across my wide-screen monitor, prefer full screen with large left and right padding. but that is a small gripe.

So CleanTalk is an anti spam filter ... hmm might want to put that back then, but I guess we'll see. We have been blessedly spam free for the most part. Of course the ability to post links is necessary so a conundrum indeed.

Cheers
I knew someone would say this after others said the other was too compact and in the center of the screen. Lol

What resolution are you at?
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

Oshyan

It's pretty hard to set margins that work for all screen widths unfortunately. Anyone above 1080p will want to view the forums in a non-maximized window. Personally at 1080p I find it works well though (any wider and it'd be too much for me).

- Oshyan

WAS

August 15, 2019, 02:04:03 pm #55 Last Edit: August 15, 2019, 02:11:38 pm by WASasquatch
Quote from: Oshyan on August 15, 2019, 12:58:48 pmIt's pretty hard to set margins that work for all screen widths unfortunately. Anyone above 1080p will want to view the forums in a non-maximized window. Personally at 1080p I find it works well though (any wider and it'd be too much for me).

- Oshyan

We could add a simple 'max-width: 1080px' 'max-width: 1920px;' for non-mobile devices, which would keep the template at a 1920 width, and keep them from growing. With 8k on the way as a standard it may be appropriate.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/

DocCharly65

So far I only recognized the new design.
I am only on a 1-2 minutes visit here and the first impression is good!

...if this post works, the second impression is as good ;)

Hannes

I really like the dark theme. But what I'm missing is a more prominent color on the "New" button (or whatever it's called) of the threads. It's grey, and I always liked the orange color which is easier to distinguish from the rest.

Dune

Unread posts should be fat and red! That's the one I always use ;)

WAS

Quote from: Dune on August 16, 2019, 01:20:32 pmUnread posts should be fat and red! That's the one I always use ;)

Honestly I just notice a huge button added before posts, regardless of colour, that says "NEW" in big bold letters. Lol Definitely noticeable regardless of color, as it's obtrusive to text flow.
Check out the Terragen Community on Facebook: https://www.facebook.com/groups/Terragen.Galleries/