RTP bug or do I miss something out?

Started by N-drju, August 08, 2019, 04:14:31 am

Previous topic - Next topic

N-drju

RTP does not work for me at all. Whenever I hit the RTP button, I am either being left with objects being the only visible features or with preview being completely black. In the latter case, the time message says RTP was completed in 0.0 - which obviously means it didn't even try...

I generally run defaults in this particular project.


So, is it like I need to turn something on to have that feature working properly?
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

WAS

Quote from: N-drju on August 08, 2019, 04:14:31 amRTP does not work for me at all. Whenever I hit the RTP button, I am either being left with objects being the only visible features or with preview being completely black. In the latter case, the time message says RTP was completed in 0.0 - which obviously means it didn't even try...

I generally run defaults in this particular project.


So, is it like I need to turn something on to have that feature working properly?

You need to let the regular 3D preview finish rendering (or get to a desire detail level), than you can click the RTP and it should start to build the RTP based on the 3D Preview.

If you have the 3D preview paused before it ever rendered anything or much of anything, it may not work properly.

Though your situation does sound weird with the immediate finish.
Check out my Terragen Discord: https://discord.gg/Vy5FRTE

Dune

If that happens, you just remove the preview window and get it back, let it run until it's finished and then hit RTP.

N-drju

Okay guys, I'll try it. Maybe it's indeed an issue with my impatience. ;)
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

N-drju

Okay, I no longer get the "blackout" but the sky still is not RTP. What shall I do now?
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

WAS

Quote from: N-drju on August 08, 2019, 03:19:37 pmOkay, I no longer get the "blackout" but the sky still is not RTP. What shall I do now?

Hmm what do you mean by that? The RTP only really effects surface textures and atmosphere/clouds as far as I know.
Check out my Terragen Discord: https://discord.gg/Vy5FRTE

N-drju

Quote from: WASasquatch on August 08, 2019, 04:07:05 pmHmm what do you mean by that? The RTP only really effects surface textures and atmosphere/clouds as far as I know.

Yes, I mean the clouds of course.

Nothing. Just an empty sky in the default color. In fact, I also don't get any surface textures... Both terrain and objects.
:-\
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

WAS

Quote from: N-drju on August 08, 2019, 04:33:08 pm
Quote from: WASasquatch on August 08, 2019, 04:07:05 pmHmm what do you mean by that? The RTP only really effects surface textures and atmosphere/clouds as far as I know.

Yes, I mean the clouds of course.

Nothing. Just an empty sky in the default color. In fact, I also don't get any surface textures... Both terrain and objects.
:-\


Hmm, at this point I don't understand why you're getting this, or what exactly you're getting (visually seeing it helps to determine causality).

Maybe you could record a demonstration of the problem, or share the file with support [at] planetside. Oshyan can take a look without you needing to share the file with the community. Additionally, feel free to email me if need be as well at jordanslost [at] gmail.
Check out my Terragen Discord: https://discord.gg/Vy5FRTE

Dune

You probably just forgot to use the buttons above the preview to see cloud and light.

N-drju

No, I start to think that this might be a compatibility issue...

I am trying to perform this RTP on an old project of mine, which was started on a different version of TG but dropped due to back-then RAM limitations.

When I try to RTP a new scene, made from TG 4.3 default, everything works out nicely! Hmm...
"This year - a factory of semiconductors. Next year - a factory of whole conductors!"

Oshyan

That sounds strange indeed. RTP should work on projects old and new. Can you provide a screenshot or, better yet, the TGD?

- Oshyan