Question about deep snow

Started by sjefen, January 16, 2020, 06:10:45 am

Previous topic - Next topic

sjefen

Hello,


I'm trying to make some deep snow and was wondering if I need to use compute terrain
and compute normal if I want the snow to be on top of some fake stones?

I must say I have no clue to what I'm doing now. I'm just trying to connect nodes until I get
what I want. It looks like compute terrain is working, but it has a huge impact on render time.


- Terje
ArtStation: https://www.artstation.com/royalt

AMD Ryzen Threadripper 1950X
32,0 GB RAM
GeForce GTX 1060 6GB

Dune

I would do something like this.

WAS


WAS

January 17, 2020, 01:25:14 am #3 Last Edit: January 17, 2020, 01:37:33 am by WAS
I'm not sure this is possible in an actually smooth and realistic manner.

There are a lot of anomalies that look like bugs to me, maybe @Matt can chime in.

For one, a continuing problem with offset/child displacement is the smooth zone of that displacement isn't coloured by the child/colour input, but is of the underlying shaders. Big issue with any of this type of snow displacement boundary stuff.

And two, for some reason the snow isn't following the slope constrictions, and on all of the stone. Smoother colour and displacement zones don't help. Patch sizes only make it rougher or polygony.

Here's a example file where I gave up.

----

One way it "sorta" works, but is just as ugly, is doing the compute normal after the stones merge group, and than using masks to colour, and add snow, but the mask boundaries cause anomalies at the base of the stones, and need smoothing, which I'm not sure how to do when the stones move along displacement of terrain. Only way I know how is displacement to scalar and adjusting it, but this includes displacement underneath (as despite preview looks at the whole node tree at render time).

WAS

Also weird anomaly in Ulco's file, where no displacement, creates a offset when sloping key is checked.

Dune

Yes, it was a very quick, rough setup, and certainly not perfect. I wish I had time for more experimentation, but alas.

WAS

Quote from: Dune on January 17, 2020, 01:39:25 amYes, it was a very quick, rough setup, and certainly not perfect. I wish I had time for more experimentation, but alas.

I saw where you were going, and is a good idea if not for all the issues. I think I have a better idea which is just blanketing the "surface" (including stones).

WAS

Yeah something is broken with the offsetting and slope keys.

Here's another example, which more or less should work, but the offset is overall, and not confined to the masked area by slopes

So colour is masked to the slopes how it should be it seems, but displacement offsetting is not.