TG hangs when canceling render

Started by sboerner, February 12, 2020, 02:54:57 pm

Previous topic - Next topic

sboerner

Terragen has been consistently hanging when I cancel renderings. The scene is fairly complex but nothing really out of the ordinary. The only way out is to kill the process . . . so I've been losing partial renderings - some after 10 or 12 hours - that I would have liked to keep.

(Trying to remember to make screen grabs before hitting the stop button.)

System has 32GB of memory. Not enough?

I canceled a rendering 2 1/2 hours ago and it's still spinning. Task manager says it's using about 7% of the CPU and 60% of the memory. Not responding and the screen is grayed out. I'll let it go for a bit more but I'll probably have to kill this one too.

:P

WAS

Are you path tracing? I've been noticing this actually as well with dense veggies and lots of fake stones for a highlander scene.

WAS


Matt

Can it be packaged up for me to test? Does it render more reliably at lower resolutions?
Just because milk is white doesn't mean that clouds are made of milk.

sboerner

Thanks, Matt. I think I'll take you up on that. I'll send a Dropbox link.

The scene renders fine, if slowly. The problem is that canceling a render doesn't stop it immediately. If the render is *very* small (480 px wide) it will successfully cancel it after a few minutes. Anything larger can take hours or hangs the application. (I've let it spin for up to 5-6 hours before killing the process.)

Not sure if there is any difference between the standard renderer and path tracer. (I use the standard renderer for small test renderings, and the path tracer for larger ones.)

WAS

This may be somehow related to clearing of RAM. Just canceled a micro-exporter for the last 30 minutes, took so long I was able to just do a lower res one in another TGD.

sboerner

OK, I think I've found the culprit. 

Before packaging the scene I decided to go through it node by node and discovered that a high-frequency surface shader (that I put together months ago) included a reflective node. Ray-traced reflections were enabled but not needed, so I disabled those. The surface shader is extensively used, so this small change made a big difference in rendering time. 

Canceling renders now seems not to be a problem now, either, though I haven't tested that yet on any large renders.

While I was at it I also checked all of the PF octaves in the scene and lowered many that were unnecessarily high. That may have helped, too.

Thanks again, Matt, for offering to take a look. But, fingers crossed, I think this is fixed.

WAS

That may make sense. It being extensively used, and If I may assume, probably not a smooth surface, so that's a lot extra overhead for rays.

Matt

Thanks for digging in and finding the culprit. That checkbox only matters with the Standard renderer. In the Path Tracer the reflections are always ray traced, but the path tracer tries to optimise these rays in different ways so it might be faster than the Standard renderer in some cases.

Let us know if the problem returns on path-traced renders.
Just because milk is white doesn't mean that clouds are made of milk.

sboerner

Thanks, Matt, I will. Appreciate the clarification on that option. I'm waiting for a larger path-traced rendering to finish. It is faster than before but I'm not seeing as much of a speed increase as I did with the standard renderer. Once it's done I'll start another path-traced render and will see what happens when I try to cancel it.