GI Cache in Water Produces Dark Areas

Started by dorianvan, March 01, 2020, 12:17:10 am

Previous topic - Next topic

dorianvan

When I use a GI cache, set to every 5 for animation, I'm getting dark areas in the water. I upped the ray detail region padding to .25, turned off fully addaptive, microvertex jittering, and detail jittering. Any idea what this could be, how to fix it?
-Dorian


dorianvan

Yeah, I should have known better. Thanks for the reminder. I will try what Matt suggested, reducing the GI cache detail or increasing the blur radius.
Didn't try path tracer with this but have with other scenes. Looks great but time is a consideration.
-Dorian

Matt

Another thing you could do is write out a GI cache file without any water in the scene, then reuse that with the water enabled.
Just because milk is white doesn't mean that clouds are made of milk.

dorianvan

Thanks. I would love to do that, but the problem is that PixelPlow uploading renders a fresh GI every time I upload an animation even though I link it to the right file/folder.
-Dorian

dorianvan

I figured out the Pixelplow problem. I forgot to add the "%04d" to the read from cache. It worked saving cache without the water, then turning on for the render. Thanks Matt!
-Dorian

Matt

I think this is a PixelPlow bug. Terragen doesn't need the %04d for the read (only the write), but perhaps PixelPlow is expecting it for some reason.
Just because milk is white doesn't mean that clouds are made of milk.

dorianvan

-Dorian