Heightfields overlapping and border blending help..?

Started by alexrabbitt, December 03, 2020, 07:09:17 pm

Previous topic - Next topic



I'm currently adding a bunch of heightfields into my scene imported from Gaea.  I'm wanting to add one which overlaps (the overlapping geometry should be covered by a lake), I've been sucessful until now, where I can't seem to get two heightfields to appear, without either having one of them seriously reduced in height while having the other disappear and vice versa.  I've also tried masking the heightfield so only a selected area of the terrain is projected however I'm not having any success with this either.  I'm also unable to get border blending to assist me.  When turning the value up, I loose one heightfield all together and when I turn the value down, I loose the other.  A balance of .5 has a faded version of both the heightfields...

I've attached some pictures to better demonstrate my issue.  Also, I'm quite new to Terragen, so excuse me if my Node tree is a mess or I'm making any obvious mistakes!  If its not apparent via my description or photos what my problem is please let me know and I'll try to provide more detail.

Thanks for all the help


It's hard to tackle this by screenshot info only, and I'm not working with heightfields, but there's two things that may help, or at least a bit. The 'fit mask to this' when masking can be counterproductive, so try unchecking that. And what if you use a merge shader, feed in both heightfields and set displacement to add?


As Ulco said, it's hard to see, what's the problem only by screenshots. Anyway, there are some more things, that should be checked:
In the location tab, there's "stitchable border", which you could test (on or off). Then under the displacement tab, there's "flatten surface first" and another parameter next to it (I haven't TG right here, so I'm not sure, what it is. I hope, this helps.