TG 4.4.67 / Is "holdout" working correctly?

Started by dzigakaiser, February 23, 2021, 11:24:26 am

Previous topic - Next topic

dzigakaiser

Hello there,


I hope you are all doing well!

I am currently working on a project with terrain and water and I wanted to render the terrain and water separately following a 3 year old post where someone asked for object IDs/mattes.

When I assign the water group to object group 1 (visible, cast shadow and rays) and all other objects to holdout (cast shadows and rays) the render still shows the terrain. 


Usually, a matte/holdout object would be black and not part of the alpha channel, at least that is how I know it from other software. Am I doing something wrong here?
tg_holdout02.JPG
tg_holdout.JPG

Thanks in advance!

Dziga

Matt

February 23, 2021, 07:54:18 pm #1 Last Edit: February 23, 2021, 07:57:28 pm by Matt
There is a bug with Holdout mode when using "Defer all shading". It should work properly if you disable this in the render settings. When you disable deferred shading it will shade each micropolygon of the water individually, as opposed to using the adaptive sampler to shade pixels/subpixels. Bear in mind that this could affect render times and/or image quality, but if necessary you can usually compensate for quality differences by changing the micropoly detail.

If you want a solution where you don't change "Defer all shading", you could put a Constant Shader at the end of the terrain/surface shaders, with colour and alpha set to 0.
Just because milk is white doesn't mean that clouds are made of milk.

dzigakaiser

Hi Matt,

thanks for the quick reply. I will have to think which solution to take in this case ^.^ 

Take care,
Dziga