Flying Tree Problem

Started by HenrikM, April 01, 2021, 01:24:46 PM

Previous topic - Next topic



As you can see in the attached screenshot, I have imported a torus object, created in Blender, into Terragen, and I am trying to attach trees to the torus, to create a giant stone bridge, with trees on top of it.

The problem is that the trees hover above the torus.

I added a Compute Normal after the default Compute Terrain, but that did not help. I have also tried playing with the Altitude key settings of the Surface Layer mask I use to mask the trees. That did not help either.

Any ideas and advice would be much appreciated. If it is possible to ditch the torus altogether, and create the bridge in Terragen, that would be the perfect solution.

/Henrik MÃ¥rtensson


It should work, populating on an object like you showed. Is the original tree object at 0/0/0. If not, that might be the problem.

Importing object, importing population, setting locations the same, anchor population to object; should work.

But here's a file with an internal cube transformed to a sort of bridge.

You can also use a number of say 10 cubes, and position them so the form a bridge. Then if you make a surface shader with a texture and displacement like rock, you could plug that into every one of those cubes through a transform shader set to final position, and the total will look as if it's one stone bridge.


And here's another (crude) method.


It works with an imported obj.
Here is a scene with a torus-bridge made in XSI and exported as *.obj.

But Dune is right. The original object has to be at 0,0,0.
There is a thread here somewhere where I ran into the same problem.

Compare the settings on each tab with the ones in my example.
Maybe there is something else. We can`t see yours, unfortunately.
The "Penguin.tgo" is not in the file. The original obj was not mine. Just use a tree instead, I guess.

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate . . . still (||-:-||)


This is the thread I was referring to in my post above.

My tree obj did had its center at 0,0,0 but the geometry was offset.
Another problem to watch out for. Don`t think this is a problem in your specific case.

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate . . . still (||-:-||)