Terragen running on Linux in 2022

Started by KlausK, December 24, 2022, 04:37:49 AM

Previous topic - Next topic


Hi there,

once again I am trying to set up a Linux Distro (like I did a lot of times in the past...).
This time I also tried to install the Terragen Render Node because I will not be updating my TG.4.5.71.Pro any time soon.
Nonetheless I would like to try and have the VDB Export feature available.

To cut a long story short - I can`t get it to work.

I cannot get Terragen to start. It hangs and gives errors about missing libraries.
About 5 or six errors I was able to solve (thx to forums).
But there is this one in particular I am not able to chase down: libpng12-0.
I searched the internet and found a few helpful threads in forums but no solution worked for me so far.
The most irritating thing about this lib is that it seems to be not used anymore in new(er) distros.

Pop!_OS_22.04 is what I am using as a standalone setup (no dual boot involved) which is nice for all 3D apps I run.
The greatest advantage to me is out-of-the-box Nvidia and AMD support. The drivers are already setup for you.
And it works fast and reliable with my RTX3900Ti.
Houdini and even a the last Softimage works flawlessly.

I also went through the process setting up WSL2 in my Win10 installation.
Again, all I installed and tried out works --> except for Terragen.
Same library, same trouble.

After spending hours and hours trying to find a solution i am about to let it be and put TG aside.
Except, maybe if someone here has a tip I have not yet found on the internet.

Do I have to use a older Linux distro for Terragen? Something around Ubuntu 18.xx perhaps? Would that help?
Any ideas thoughts much appreciated.

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate . . . still (||-:-||)


Try to add the source for that version

sudo add-apt-repository ppa:linuxuprising/libpng12
sudo apt update
sudo apt install libpng12-0


Thank you, @WAS ! I had hoped you would come to the rescue.

On my standalone POP!_OS_22.04 installation I already tried this and cannot make it work.

This is what I get:

Repository: 'deb https://ppa.launchpadcontent.net/linuxuprising/libpng12/ubuntu/ jammy main'
libpng12-0 for Ubuntu 20.10, 20.04, 19.10 or 19.04: https://www.linuxuprising.com/2018/05/fix-libpng12-0-missing-in-ubuntu-1804.html
More info: https://launchpad.net/~linuxuprising/+archive/ubuntu/libpng12
Adding repository.
Press [ENTER] to continue or Ctrl-c to cancel.

Adding deb entry to /etc/apt/sources.list.d/linuxuprising-ubuntu-libpng12-jammy.list
Adding disabled deb-src entry to /etc/apt/sources.list.d/linuxuprising-ubuntu-libpng12-jammy.list
Adding key to /etc/apt/trusted.gpg.d/linuxuprising-ubuntu-libpng12.gpg with fingerprint 1CC3D16E460A94EE17FE581CEA8CACC073C3DB2A
Hit:1 http://packages.microsoft.com/repos/code stable InRelease
Ign:2 https://ppa.launchpadcontent.net/linuxuprising/libpng12/ubuntu jammy InRelease
Err:3 https://ppa.launchpadcontent.net/linuxuprising/libpng12/ubuntu jammy Release
  404  Not Found [IP: 443]
Hit:4 http://apt.pop-os.org/proprietary jammy InRelease
Hit:5 http://apt.pop-os.org/release jammy InRelease
Hit:6 http://apt.pop-os.org/ubuntu jammy InRelease
Hit:7 http://apt.pop-os.org/ubuntu jammy-security InRelease
Hit:8 http://apt.pop-os.org/ubuntu jammy-updates InRelease
Hit:9 http://apt.pop-os.org/ubuntu jammy-backports InRelease
Reading package lists... Done
E: The repository 'https://ppa.launchpadcontent.net/linuxuprising/libpng12/ubuntu jammy Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Of course, I can get to the site with these folders via the given IP.
But I am lost when it comes to choose which file I should download there, where to put it in the file structure in Linux
and - last but not least - how to then install it...

BUT - There is good news after all:

I was able to install the packages in the Ubuntu_20.04 WSL2 environment. Yeah!
Used your commands and there were no errors with the repository.
And Terragen is actually starting up and running.
So far so good.

BUT: my license is not accepted :'( :'( :'(
which must be a mistake. My license is valid for 4.5.71 Professional.
And it is a Perpetual license I bought back in 2016  and renewd in 2019. I would be quite surprised
if a Maintenance Renewal in 2019 would have left me with a Non-Perpetual license.
But I am going to present that to Planetside support after the holidays. I hope they can fix this.

So, thanks again for chiming in here @WAS.

ps: ...and they say Houdini has a steap learning curve....
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate . . . still (||-:-||)


Ah yes, they apparently don't have SSL going, raw IP and all that, so you will need to manually add it as trusted. See this topic which is far less convoluted then a manual page: https://askubuntu.com/questions/732985/force-update-from-unsigned-repository


Thank you. I`ll take a look.

CHeers, Klaus
/ ASUS WS Mainboard / Dual XEON E5-2640v3 / 64GB RAM / NVIDIA GeForce GTX 1070 TI / Win7 Ultimate . . . still (||-:-||)