Translucency??

Started by Njen, January 04, 2007, 12:23:01 pm

Previous topic - Next topic

Njen

January 04, 2007, 12:23:01 pm Last Edit: January 04, 2007, 12:49:43 pm by njen
I am building a volcano scene, and I am at the stage where I wanted to make cracks on the ground, and have a very large plane sitting just underneath the ground that is bright orange to simulate the light coming from lava. But my surfaces seemed to be brighter than before. So I disabled everything except the terrain, the plane and a light source, and did a render with the plane enabled (unhidden) and disabled (hidden). Now I know it's been mentioned that translucency is not available in the technology preview, but it sure looks like some sort of translucency or subsurface scattering to me.

While this is a cool effect for other situations, I do not want the plane to affect the terrain surface in anyway. How do I stop this?

[Edit] the third image is exactly the same settings, only I inserted a Default Shader on top of the base colours because I thought it might reset the shader on the terrian, but it only increased the effect.

Njen

Ok, I just turned off my environmnet light and the effect went away. So it's the global illumination I guess. Now here's the thing, I want global illumination on, because of it's effect in other areas of the image I have made, but I don't want the terrain to receive this translucency like effect. How do I acheive this?

Njen

January 04, 2007, 01:15:10 pm #2 Last Edit: January 04, 2007, 01:48:40 pm by njen
I seem to be having a nice old conversation with myself here ;)

But I think I have a temporary solution. I made a copy of the planet, and made it a *touch* smaller than the original one. While the light passes through one surface easily, it can't pass through 2 surfaces very well. I still have small areas that are a *little* bit brighter, but it's not that noticeable. Of course I have now doubled my polycount, but I hope a solution to this comes soon enough.

The first image is with the single planet and the cracks. You can see the light coming through the back face of the terrain from the plane. The second image has the second planet in there, which blocks a lot of the light from the back face, while still allowing the lava to cast a GI effect from the cracks.

MeltingIce

Did you try playing around with the luminance setting?  When a texture has luminance it emits light during global illumination calculation.  If you can restrict the altitude of the shader with luminance, then you can eliminate your smaller copy planet.

MeltingIce Network | Wii Number: 3881 9574 8304 0277

Njen

January 04, 2007, 04:58:01 pm #4 Last Edit: January 04, 2007, 04:59:43 pm by njen
I understand about luminance emitting light. That's exactly what I want the plane underneath to do (in the cracks) What I don't want it to do is to be able to be calculated on the back facing geometry above it. Plus there is nothing to restrict as far as altitude for the shader as the plane is completely flat and under the ground. The terrain above has no luminence in the shader at all.

Oshyan

I wonder if you could decrease the Enviro Light's effect on terrain but still get the GI lighting effect from luminous surfaces. Something to try!

- Oshyan

rcallicotte

njen, I like what you finally came up with.  I didn't even know about this thread until now.  Bookmarked.
So this is Disney World.  Can we live here?

Will

Yes keep us posted on this!

Regards,

Will
The world is round... so you have to use spherical projection.