Heightfield want reload after restart TG2

Started by Landix, August 05, 2008, 10:47:38 am

Previous topic - Next topic

Landix

Hi,

when i save a project with a heightfield, and i want load it again the heightfield is missing, only a flat plane is showing up!?
When i render the project no heightfield are coming up.

my file here:


My version is TG2 P5 1.9.99.1 Licensed to me :)

is a bug, or an fault from me?!

red_planet

Landix...

If I'm not mistaken.. this is simply a case of ticking the "Auto generate" box (Next to the generate now button !) in the Heightfield Generate dialog which is accessed from the Heightfield Shader.

Rgds

Chris

Landix

Thx for the reply,

i have tick auto generate on.

so on every load of the project file, it must build the heightfieds!?

cost much time  :'(

But it works first  :D

Tangled-Universe

Quote from: Landix on August 05, 2008, 12:17:39 pm
Thx for the reply,

i have tick auto generate on.

so on every load of the project file, it must build the heightfieds!?

cost much time  :'(

But it works first  :D


Of course you'll have to, since the heighthfield is generated procedurally.
Unless you want to save procedurally generated heighthfield the size of a planet ;)
It cost indeed some (little) time but luckily enough it's only about once per session!

Oshyan

Or you can simply save the heightfield once you initially generate it by right-clicking the heightfield generate and choosing Save (make sure to specify .ter file extension), then replace the Heightfield Generate with a Heightfield Load and it should auto-load when you open the project. No need to regenerate. Of course if you want to change the heightfield settings later you must regenerate (and if you removed the Heightfield Generate, you will not be able to do so, of course, so don't delete it).

- Oshyan

Landix

Quote from: Oshyan on August 12, 2008, 03:09:24 am
Or you can simply save the heightfield once you initially generate it by right-clicking the heightfield generate and choosing Save (make sure to specify .ter file extension), then replace the Heightfield Generate with a Heightfield Load and it should auto-load when you open the project. No need to regenerate. Of course if you want to change the heightfield settings later you must regenerate (and if you removed the Heightfield Generate, you will not be able to do so, of course, so don't delete it).

- Oshyan


That is helping!
thx