bucket error on low res scene

Started by reck, July 21, 2008, 06:45:18 pm

Previous topic - Next topic


I've been rendering a project for 23hrs tp5 and everything was going ok, it had reached the last line of the render and then disaster struck.  The render crashed and I got some memory errors. I think the bucket word was mentioned. It just so happened that I had task manager open at the time and memory consumption was at about 70%. With TG using about 830MB of memory.

Any idea why the render run out of memory towards the end? The scene consisted of 1 population of grass and was being rendered at .8 detail level with a  resolution of 800x600. At such a low resolution with one population I don't understand why it ran out of memory. I have 4GB in this system.

Will memory utilisation be improved in future versions? Also is it worth me messing around with the subdiv cache, would increasing/decreasing this have preventing the crash do you think?

The other annoying thing is the render had mostly finished and it had been going for the best part of the day before it ran out of memory. If I turned on preallocate subdiv cache would this have made TG tell me at the start of the render that I needed more than 4GB of memory?



Do you have a project file you could send us?




Hi Jo, email sent to planetside support email


If memory use was not above 2GB it may not have been a memory issue, so preallocating the subdivision cache might not have helped you find out earlier. But it's worth a shot. Changing the subdivision cache (smaller or *larger*) may also help. We'll look at the scene you've sent - thanks.

- Oshyan


Hi, have you had chance to take a look?

Just tried again and it's still crashing in the same place, the last line of the render. Terragens memory usage was only around 1GB and overall memory usage about 60% so something with the memory allocation is going wrong it seems.

I tried to capture the error message that came up but unfortunately the error box was transparent this time, but the time before I remembered it said something about memory or buckets or both.


Great scene you got here. Very realistic. Hope you get this fixed, reminds me of bits of Southern UK.

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)