Totally black render (Again)

Started by Mr_Lamppost, January 23, 2009, 08:32:31 PM

Previous topic - Next topic


The problem I am having may be related to the one described here:
but there are differences.

I am working on a scene, no extreme settings but a few populations, again nothing extreme; a few thousand instances each.  From a complete re-start; Windows (XP or Vista), and TG.  Even a low resolution, low quality test render completes but with a completely black image and no errors or warnings.  Just in case this is a memory issue I have restricted TG to using one core; no help.  If I disable a population of Eucalptus trees made by JCinBAMA  the scene renders correctly.  If I leave this population but disable all the others It renders black.  I don't think it is the object as I have tested that by rendering a separate scene containing a population with many more instances than I need without error. 

I can complete my scene as this population is not vital but it is interesting that a single population, one of many can cause a problem.

Smoke me a kipper I'll be back for breakfast.


This might be totally off base, but is it possible that the camera is actually in the trunk of one of the Eucalyptus trees from that population?  Try changing the seed value or move your camera to see if that is the case.


Ooops, should have mentioned that I tried that.   :-[

Perfectly reasonable assumption though. 
Smoke me a kipper I'll be back for breakfast.

Kevin F

Does the scene actually finish rendering with no error report or is it just taking forever to start?


The render runs for about the same time as it does without the problem population and completes with the Finished Rendering message as normal.
Smoke me a kipper I'll be back for breakfast.


And does the GI pass render with colour, or is that black as well?


Totally black all the way.  I thought it was just taking ages to start the GI pre pass at first but then I noticed that the render had finished. 

This is strange though: If I delete the population of Eucalptus trees then add the population again using the same parameters the scene renders. 
Smoke me a kipper I'll be back for breakfast.


I had a similar problem and I'm not remembering why the population caused that...or triggered it.  I think it might have had something to do with my camera being affected by the population, covered or blocked...can't remember exactly.
So this is Disney World.  Can we live here?


I've run into this before.  I don't remember what caused it, but I think I solved it by deleting one of my shaders and rebuilding it. 


Have you tried moving the camera a *significant* amount to see if it renders from *any* angle at all? Or does it simply not render from any position with that object enabled?

- Oshyan