Unknown error in traceray

Started by PorcupineFloyd, April 25, 2009, 02:44:14 pm

Previous topic - Next topic

PorcupineFloyd

April 25, 2009, 02:44:14 pm Last Edit: April 25, 2009, 02:47:42 pm by PorcupineFloyd
Hi,

I was just rendering a nice scene with lots of vegetation and while the GI prepass was finishing - an error window pop up with couple of "An unknown error occurred in TraceRay" and some "An unknown error occurred in trBucketRender::RenderMore()ray-traced pass" leaving some prepass area black. I thought that it will crash TG but it continued to render. However, I cancelled it as I didn't want to spent 20 or more hours just to know that my render is quite destroyed.

Before cancelling the render I've noticed that tgd.exe is using 2.8 GB of memory. Is my problem related to TG being unable to address more memory than needed? My scene has lots of different populations (3 grass clumps and 5 models). Is there a way to limit memory usage without getting rid of some populations?

By the way: When can we expect a 64 bit version of TG2?

PS. can someone move it to TG2 support sub-forum?

neuspadrin

well.... the dots in the foreground look pretty  ;D

PorcupineFloyd


buzzzzz1

Have you tried lowering your subdivide cache from 400 too 200? Might help?
XFX 750i SLI  nFORCE Mobo
Intel Core2 Duo E8400 3.00 GHz Wolfdale
8 Gig Corsair DDR2 6400
Nvidia GForce 9600 GSO 768 MB
XP Pro 64 bit OS

PorcupineFloyd

I'll check that out, thanks buzzzzz1.

neuspadrin

try preallocating the memory too

PorcupineFloyd

April 25, 2009, 03:23:24 pm #6 Last Edit: April 25, 2009, 03:45:20 pm by PorcupineFloyd
I've got preallocate enabled.

EDIT:
I've reduced the amount of blades in grass clumps and lowered quality from 0.8 to 0.75. Let's see if it helps.

cyphyr

thats a VERY fine pre-pas you got going there, how high are your AA~detail~supersample etc settings, you may be able to drop them just a tad and avoid the errors.
richard
www.richardfraser.co.uk
https://www.facebook.com/RichardFraserVFX/
/|\

Ryzen 9 3900X @3.79Ghz, 64Gb (TG4 benchmark 6:20)
i7 5930K @3.5Ghz, 32Gb (TG4 benchmark 13.44)

PorcupineFloyd

I've got GI set on 2/4/8 as there are lots of vegetation (esp. grass). Supersample enabled.
AA is set on 7 samples with tent filter.
Soft shadows are 1/10.
Quality was 0.8 and now I'm rendering at 0.75.
Atmosphere - 42
Clouds - 320

Hetzen

I think the top corner looks perfectly fine. You should have left it to run. ;D

Oshyan

That's definitely a memory issue. You cannot limit total memory use in an arbitrarily complex scene because there are simply certain requirements for rendering particular scene elements. You can't get around the need to load an object into memory if it needs to be rendered, for example. The best you can do is to reduce the size of the render cache, but this can only save perhaps 200MB on a quad core system (or 300MB on a dual core - there is a minimum of 50MB per core).

64 bit support will be one of the next things we focus on, but we have no release date for it yet. It will be a free update for registered users. In the meantime moving to a 64 bit OS will help you as you can use up to 4GB of RAM, and of course you will be ready for when 64 bit TG2 is available.

- Oshyan


PorcupineFloyd

Thanks Oshyan.
So far - it's rendering. It looks like reducing some parameters helped.

I'm on Vista x64 by the way and the scene atm is using 3.2 GB of memory and it's 1/4 completed.

PorcupineFloyd

I've tried to re-render it.
Hopefully it completed the pre-pass and was like 1/3 done. After few hours I came back home only to see a beautiful wallpaper on my desktop. No sign of Terragen instance open.

Oshyan

I would try reducing the GI sample quality back to 2. Also what are the quality settings of your populations?

- Oshyan

PorcupineFloyd

Populations are at medium. I'll try to render this scene without trees on the rocky background and see if it helps.