Can't get Terragen Free Edition to work at all

Started by lnexus, May 31, 2009, 01:05:33 am

Previous topic - Next topic

lnexus

Hi,

Everytime I start Terragen 2 Free Edition, the editor window opens but then freezes and stops working. My System: Vista 64 Ultimate/Core i7 920/Ati 4870 1gb

Any help appreciated.

neuspadrin

Any error messages?

Try

Start -> type "cmd" and press enter

Copy this line below (including quotes)

"C:\Program Files (x86)\Planetside Software\Terragen 2 Free Edition\tgdcli.exe" >> error.txt

Now, upload the error txt file to the board (or copy and paste it in).  Then maybe we can see where it's hitting something.  It will be located in your user folder (C:\Users\(Your username here)\error.txt).  This is also assuming you install to the drive C, change that letter to D or whatever your program files are at.

Most likely you need to make sure all drivers are up to date, windows is up to date, etc.

lnexus

Thanks for helping out. No error messages. Just seems to stop responding at this step: creating camera (268634224). Link to whole file: http://pastebin.com/m1488c466

Oshyan

Are you on an English version of Windows? Are you running it as admin? Do you have the latest version of your graphics card drivers?

- Oshyan

lnexus

Quote from: Oshyan on May 31, 2009, 03:03:34 am
Are you on an English version of Windows? Are you running it as admin? Do you have the latest version of your graphics card drivers?

- Oshyan


Yes I am on an English version, tried running it as admin and on xp compat. mode with the same error.

I am downloading the latest driver. I had the version prior to that one. I will report back in a few minutes.

lnexus


Oshyan


lnexus

Sorry to bump this but it worked once, then stopped working again. How is this possible? It's still getting stuck at the same line: creating camera (268634224). I have the latest driver installed. The only time it worked was right after I installed the latest drivers for my graphic card and didn't restart my PC when it asked me to but launched Terragen.

Oshyan

Given that it has worked several times previously and that driver updates appear to have at least temporarily resolved this in the past, and that nobody else seems to have encountered this particular problem, I'm afraid it appears to be system specific. We're not able to duplicate the issue here so it's virtually impossible to track it down. However it does seem like the point at which it's failing may be just before certain OpenGL (graphics system) calls are made, in which case - as already appeared to be the case - it is probably related to your graphics card.

I definitely think you should look into your hardware and software configuration and make sure there are no other problems. You could try turning down Graphics Acceleration in the graphics card driver, or turning off Aero if you're on Vista and it's enabled. You might even try reverting to a previous driver revision. You might also consider reporting it to your graphics card vendor. If nothing else, hopefully another future driver update will resolve it.

- Oshyan

Henry Blewer

Check the quality settings of the graphics card. When I am working with video, having the graphics cards settings cranked up all the way causes crashes. I have a profile saved for my Radeon card so the settings are all standard, and the quality is 'balanced'. If I play a game, then I change the profile to the higher quality levels.
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

Klas

June 20, 2009, 02:14:34 pm #10 Last Edit: June 20, 2009, 02:28:27 pm by Klas
Quote from: lnexus on June 14, 2009, 01:10:01 amIt's still getting stuck at the same line: creating camera (268634224).
That is the same output as on my computer. Is TG really freezing or can you close the TG2 normally? Which driver do you use? The latest is 9.6, Ati drivers can be found here: http://support.amd.com/de/gpudownload/Pages/index.aspx . You can also try the DAN drivers at http://www.donotargue.com/list.php?c=dnaati . Have you enabled Aero? Turn it off.

/edit
Oh, and download the driver with the Catalyst Control Center, 57,9 MB.

lnexus

Thanks for the help guys. I've finally found what was wrong. It was a software that came with my Asus 4870 card called GamerOSD. I removed the software and everything works now! I had a problem with photoshop cs4 also where it would crash each time I tried the 3D functions, it solved this problem also.

Henry Blewer

http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T