this scene crashes the CLI client reliably

Started by Falcon, July 03, 2009, 04:24:21 am

Previous topic - Next topic

Falcon

The attached scene has reliable crashed the CLI client three times, always at the same position (1:59 into rendering on this iMac).

I have no idea what causes it, I'm trying a GUI render now to see if it produces any debug output. If it does, I'll attach that.

The crash causes no output on stdout. I didn't redirect stderr to anything, so I'm not sure if it wrote anything there. Actual commandline was:
nohup tgdcli -p Alpine5-N.tgd -exit -r -o Alpine5-N.exr &

The last lines in nohup.out:

Rendering final pass... 1:58:00s, 3874806 micro-triangles
Rendering final pass... 1:58:30s, 3874806 micro-triangles
Rendering final pass... 1:59:00s, 3874806 micro-triangles
Rendering final pass... 1:59:30s, 3874806 micro-triangles

and then it just stops.


Falcon

GUI render of the SAME .tgd works. Runs about 2:05 on the same machine, but completes without errors or warnings.

jo

Hi Falcon,

I'll give it a whirl. It possibly won't matter, but can tell me what version of OS X you're using and whether you have an Intel or PPC iMac.

There may also be helpful information in the crash log. To see the crash log start the Console application and look in the log list at:

~/Library/Logs
CrashReporter
Terragen 2.crash.log

Regards,

Jo

Falcon

July 05, 2009, 05:10:54 pm #3 Last Edit: July 05, 2009, 05:13:16 pm by Falcon
Darwin Slaanesh.local 9.7.0 Darwin Kernel Version 9.7.0: Tue Mar 31 22:52:17 PDT 2009; root:xnu-1228.12.14~1/RELEASE_I386 i386

Should be OS X 10.5.7 on an Intel Mac.


I've attached a crash log. I can not be sure if this is from that crash, because the job was running in a batch. But it is the latest crash, there is no crash log from later on. If this isn't it, then the crash did not produce a crash log. I fear the later, because I'm fairly sure that I ran the other tries later than the 30th.