Reflective shader bug?

Started by Kadri, August 14, 2011, 11:28:36 am

Previous topic - Next topic

Kadri

August 14, 2011, 11:28:36 am Last Edit: August 23, 2011, 05:55:13 pm by Kadri
After i bought TG2 i wanted to make a bigger render of this:
http://forums.planetside.co.uk/index.php?topic=7815.0

This project was-is full of problems. Not all of them are related to TG2.
But i learned many things on the way :)

Anyway!

There were black parts. I tried many things. No cure!
I am too stubborn sometimes. I didn't wanted to say there is a bug etc. before i tried all i know.

After some days i left it and tried it after a couple weeks later with Oshyan's fill light setup.

It looked good at first.
I couldn't see bad black parts in the render at first. But then i saw something else on the space ship.
Checkerboard kind of patterns.Light and dark parts .

I tried ones more all i know with the render settings etc.  No cure!

If the image hadn't in the first place black bad renders everywhere i would have seen it maybe earlier.
These dark and light parts where mostly on the prominent reflective parts.

After many tests i think there is a problem in this "Reflective shader" .
There are some posts here on the forum but i could not find this specific kind of problem.
If this is a known problem i am wasting my and your time now ...

To see if the problem isn't related to my object i tried it with basic objects .
There was the same checkerboard pattern.

Then i thought maybe it is the same on other native TG2 objects.
Please try this:

1- Open a new default scene in TG2.
2- Shaders+Add Layer+Other surface Layer+Reflective shader
3- Delete all other nodes above "Reflective shader" . (with or without them it is the same)
4- Go to Full Render and make the image 200x200 for faster testing.
5- Render... There is no problem!
6- Open the Reflective shader node and pull the  "Reflection softness" slider to the right ( 0.8 ) .
7- Render again...Yes here it is! Checkerboard pattern.


When i first saw that it has to do with the "Reflection softness" i thought after some test that there is a threshold but i think now it gets only less prominent with smaller settings.

After lowering the number of samples to 1 in the Quality tab of the Reflective shader the pattern vanishes .

Interestingly if you use only 1 thread in the "Full Render"  Advanced tab you do not get this problem too.
So if you try this with a computer that only have one core you might not get this pattern at all.


I tried many other settings but the only working solution for me were these 2 above.

I looked at the older images that i made with the free TG2 v2.2 and i could not see such patterns.
It looks like it is new to this build to me.

I use  Windows 7 Ultimate 64 bit and TG2 with animation v2.3 (build 2.3.20.1) 64 bit .


Henry Blewer

I had this happen also in a render or two. I think it had something to do with the GI settings in the render tab. Did you  enable these and super sample prepass?
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

Kadri


I tried maybe all combinations that are Render and Reflection Shader node related (some unsupported ones too) but it doesn't changed.
There could be ones that i overlooked of course , Henry !

dandelO

August 14, 2011, 05:16:06 pm #3 Last Edit: August 14, 2011, 07:32:32 pm by dandelO
I've had this problem before, too, Kadri.
Reflection softness is extremely buggy.

I made a file some time back and posted to the threads(one in image sharing/one in file sharing) called 'Anisotropic reflective shader'. You might be able to use a different noise than the sine patterns that I used to blur reflections, you can lower the tiny displacement further, reduce the sine scale(which is already tiny at '0.00025m'), and change the direction of the grain...

Image sharing post; http://forums.planetside.co.uk/index.php?topic=11326.0
File sharing post; http://forums.planetside.co.uk/index.php?topic=11333.0

dandelO

August 14, 2011, 07:24:10 pm #4 Last Edit: August 14, 2011, 07:45:47 pm by dandelO
Quick example of my softer reflections workaround, Kadri...

[attachimg=#]

The settings that I changed from the default file I shared was only to lower the amplitude of 'displacement shader'(found inside) from '0.0005' to '0.00025'.

It doesn't 'blur' the reflections like the reflective shader 'softness' setting does but it's pretty editable to make some nice effects.
Reflection 'sample quality' settings aren't required, either.

dandelO

Some (Cubic B-Spline)soft AA can help to smooth out the 'blur' noise...

[attachimg=#]

Both images with AA=6(max samples). Top one is Mitchell-Netravali.

dandelO


Kadri

Quote from: dandelO on August 14, 2011, 10:27:24 pm
Updated(v.2) of this shader, with far greater user control is now here;
http://forums.planetside.co.uk/index.php?topic=11333.msg128492#msg128492


First download by me DandelO. Thanks for the file :)
I will try it now.

Kadri



Planetside?
Is there any news on this "Reflective shader" ?