Lake Curvature ?

Started by Falcon, April 12, 2010, 08:54:29 am

Previous topic - Next topic

Falcon

The guide says a lake/water object is adjusted to the planet, hence the planet link.

I don't see any adjustment in my lake (which is set to 10x the default in size). Which makes the terrain to the edge of my view area dip under the water where it shouldn't.

Anything I'm doing wrong, or a workaround?

Henry Blewer

The lake is a flat plane. So the edges continue level like a piece of plywood on a child's ball. Add a sphere object. Copy the planet's size and location to the sphere's inputs. Now resize the sphere so the area you want to be water is covered. Now add the water shader where the default shader is,
http://flickr.com/photos/njeneb/
Forget Tuesday; It's just Monday spelled with a T

TheBlackHole

Yep. njeneb's right. Create a sphere, then put it at 0, -6.378e+006, 0. Set the radius to 6.378e+006 and then tweak it to get the right size lake or ocean. Replace the Default shader with a Water shader (don't change any water settings unless you need to). That's how people do it on their TG2 planets if they want planetary-scale oceans, but it also works for smaller bodies of water.
They just issued a tornado warning and said to stay away from windows. Does that mean I can't use my computer?

Oshyan

By default Planet 01 is specified in the Planet tab of your Lake node. This does create curvature to the planet, but it's not as accurate and precise as doing it with a duplicate sphere/planet as others suggest. It's not ideal for large lakes, in other words. Removing the Planet 01 node reference from the Planet tab will remove any curvature though.

- Oshyan