Planetside Software Forums

Support => Terragen Support => Topic started by: moreno on January 16, 2012, 10:58:38 am

Title: Clouds take shader color
Post by: moreno on January 16, 2012, 10:58:38 am
Hi, i have a problem. Clouds take the color of the shader (base colours or any other shader) ,i've spent a lot of time to understand but no results. I've a 4-core pc,nvidia geforce gt 545,windows 7 home premium.
Title: Re: Clouds take shader color
Post by: Tangled-Universe on January 16, 2012, 12:13:42 pm
What you see is the effect of GI.

If you go to your cloud node and under the lighting tab set "enviro light" to 0.
Now you have disabled the contribution of the "enviro light" node (which by default is set to GI) to the cloud.
Tadaaa...gray clouds, but no indirect lighting effects anymore (logically).

You can achieve the same by setting the "strength in atmosphere" to 0 in the "enviro light" node, but that would affect all atmosphere elements.

What you can do:

1) Use normal surface shader colours ;)

2) If you want lollipop colours, then you can try the following:
go to the cloud node and under the lighting tab set the "enviro light tint" to R=255, G=128 and B=255 and press OK.
What you did is telling the cloud node to treat the indirect light, generated by the GI, differently.
With the default white colour every colour channel is treated the same, but by reducing the weighting for the green channel, by setting it to something <255, you have removed the contribution of green indirect light to the clouds.

If you want to correct the colours for all atmosphere elements you should do the same operation for the "colour in atmosphere" in the enviro light node.

Cheers,
Martin
Title: Re: Clouds take shader color
Post by: Kadri on January 16, 2012, 12:37:43 pm
Quote from: Tangled-Universe on January 16, 2012, 12:13:42 pm
...go to the cloud node and under the lighting tab set the "enviro light tint" to R=255, G=128 and B=255 and press OK.
What you did is telling the cloud node to treat the indirect light, generated by the GI, differently.
With the default white colour every colour channel is treated the same, but by reducing the weighting for the green channel, by setting it to something <255, you have removed the contribution of green indirect light to the clouds.
If you want to correct the colours for all atmosphere elements you should do the same operation for the "colour in atmosphere" in the enviro light node.


Nice tip Martin.
Title: Re: Clouds take shader color
Post by: moreno on January 17, 2012, 08:05:08 am
Thank you very much Martin, now i can go on !