Planetside Software Forums

Support => Terragen Support => Topic started by: RArcher on July 05, 2007, 02:28:58 pm

Title: GI water and reflections problem
Post by: RArcher on July 05, 2007, 02:28:58 pm
I tried searching but did not have anything relevant come up.  I am rendering a panorama made up of many 800 x 600 images, and there have been some fairly random angled shadows (or possibly areas where GI isn't working) showing up in random areas of the water on each tile.  I have included an example tile with GI at 2/2 and one with it off completely.  While it might not seem like a big deal to go with GI off on this particular tile since it still looks OK, on some of the other tiles the landscape is too dark without a bit of a boost.  Would using the Fill Light setup cause this sort of issue as well?

If this has been seen before or there are other workarounds, could you please direct me to the thread in particular?

Thanks!
Title: Re: GI water and reflections problem
Post by: old_blaggard on July 05, 2007, 03:42:46 pm
Firstly, this looks like an AWESOME scene, and I can't wait to see the final panorama.  Secondly, I'm assuming you're talking about that large shadow in the lower part of the image as your problem.  From what I can tell, the sun is coming from behind the camera in this picture - is it possible that it's simply a shadow from something behind the camera?  I don't know why it wouldn't show up in GI 0/0, though, which means all of the above could very possibly be rubbish.

Ok, nevermind, scratch that :P.  I'll just leave it at "This looks really promising and I hope you can work it out" ;).
Title: Re: GI water and reflections problem
Post by: Oshyan on July 05, 2007, 04:05:49 pm
It does look like a shadow, that was my first thought as well. It's hard to say exactly what the problem is without looking at an example scene to know more about the settings involved. Determining whether a fill light setup would work better in this case is also difficult without finding the root of the problem but given that it seems to be related to GI it's very possible that using fill lights would fix it. If you want to provide a file to diagnose you can post it here or send to support@planetside.co.uk

- Oshyan
Title: Re: GI water and reflections problem
Post by: RArcher on July 05, 2007, 04:17:08 pm
Thanks, I will send the file as soon as I get home from work.  It is definitely not a shadow though.  Here is the tile directly below the one posted above, with the exact settings (only the angle has changed from -15 degrees to -45 degrees).  The top third of the image is overlap from the bottom third of the image posted above.  You can see that in this case, the dark shadow does not exist, however there is a very similar issue at the very bottom of this image as well.  The problem occurs in varying degrees in each of the images I have rendered that contain water so far.

In any case I will send you the file, Thanks!
Title: Re: GI water and reflections problem
Post by: bigben on July 05, 2007, 07:06:45 pm
This looks similar to the problem I had with no GI below the equator. While it appeared to be a straight line in mine, different settings did seem to change the shape of the edge a bit and the shape was similar to this.

It got me thinking to possible contributing factors, and as this is over water, and most of my image was water (reflectivity shader only) I tried turning reflectivity off. While the problem didn't go away, the area with GI was bigger, covering part of the top end of Australia. I'm running an uncropped render now (going to take a few hours).

It might be worth seeing what happens with this file, with the cloud layers disabled?

I'll try changing the camera rotation in mine to see if that makes any difference as well.
Title: Re: GI water and reflections problem
Post by: RArcher on July 05, 2007, 07:42:23 pm
Here are a further two images that should seamlessly overlap about 1/3rd of the way vertically, but they have radically different "shadows".

I am running a few more tests with GI on and off, with fill lights and with the clouds removed.

The first image is at 45 degrees, with an angle of -15.   The second is at 45 degrees, with an angle of -45.
Title: Re: GI water and reflections problem
Post by: RArcher on July 05, 2007, 08:24:31 pm
More tests...

First image is with the cloud layers disabled.  The odd shadow is still present, but the edges are not as defined.

Second image is with the clouds disabled, and both atmosphere and shadows turned off in the render tab.

Next test is fill lights.  My scene really isn't very complicated so I've about run out of ideas.
Title: Re: GI water and reflections problem
Post by: bigben on July 05, 2007, 09:49:37 pm
Is this area using an image map?
Title: Re: GI water and reflections problem
Post by: RArcher on July 05, 2007, 10:35:25 pm
No image maps at all, I have a few fill light setups rendering with GI off and it the problems seem to have gone away, so I expect it to just be another GI error.  Some new problems with the fill lights leaving white pixel artifacts now though.  Thankfully that is a simple fix in Photoshop.
Title: Re: GI water and reflections problem
Post by: Volker Harun on July 06, 2007, 09:09:03 am
It is a very interesting topic - and I am not able to understand how this happens, but ...

First of all, you seem to be aware of the fact that it is a GI problem.
Second you know that GI and panoramas, stitched pictures and so on do not like each other.
Else you would not make overlapping renders - or does your stitcher need overlaps?
Then, why not turn off the GI?
It takes rendertime and the above pictures tell me that you really do not need them.

,-) Volker
Title: Re: GI water and reflections problem
Post by: DeathTwister on July 06, 2007, 05:17:50 pm
Wow I am dumbfounded that you guys are this far.  We have been trying to get water in TGD2 transparent for a bit, and here is the topic at: http://forums.planetside.co.uk/index.php?topic=1766.new;topicseen#new (http://forums.planetside.co.uk/index.php?topic=1766.new;topicseen#new)
but have not figured out how to get the water so we can see through it, you have as I can see the bottom, even if there is a shadow or artifacting going on driving you nuts. It's farther then we have figured it out so far.

Would you please, please, please either share a simple tgd2 file so we can see what you did to get the water the way you have it now so far, or better yet if you have the time make or share a tutorial so we can figure it out how to get the water to look like that.  As it is, the water block (Lake) there is no easy way to change the color or to get the water transparent at all in this preview version.  So I figure it has to be setting up the nodes right somehow, but have not got it figured out yet.  Would you help us poor dummies like me get that info???????? /bows humbly.

DeathTwister
Title: Re: GI water and reflections problem
Post by: Volker Harun on July 06, 2007, 07:56:53 pm
DT  ;)
This seems to be just some foam and reflection, that gives you the illusion of transparency.
The trick is to keep everything calm and quiet on the water  ;D

Volker
Title: Re: GI water and reflections problem
Post by: bigben on July 06, 2007, 09:35:44 pm
Quote from: Volker Harun on July 06, 2007, 09:09:03 am
Then, why not turn off the GI?


In the short term, yes, turn it off...

But then finding out when GI has problems (and what changes are made to get it to work) can help the developers isolate where the actual problem is and hopefully get it fixed quicker.
Title: Re: GI water and reflections problem
Post by: RArcher on July 06, 2007, 09:46:37 pm
Exactly! I would much rather try with GI first and then if it doesn't work correctly find an alternative and give the developers a chance to correct the bugs or problems all the sooner.  This is the other reason as well Volker, even though the image posted looks OK without GI, other sections in the panorama look terrible without it (see below).  Thankfully the Fill light setup is working very well so far.

Deathtwister:  I posted what I did to the water in the fake transparent water thread.  It isn't as fancy as I think you wanted it to be... but it does give a passable effect.
Title: Re: GI water and reflections problem
Post by: DeathTwister on July 06, 2007, 10:19:37 pm
RArcher,

Cool, could you shoot a link to that by chance? I have not found that one yet.  Sounds like a good idea though. using a fake transparent water shader, wait do we have one? I never saw it hahahaha, KK maybe send a link in case I don't find it f I could ask?  Thanks on the heads up though, lots of posts to look through, I get lost at times.

DT
Title: Re: GI water and reflections problem
Post by: Volker Harun on July 07, 2007, 04:33:33 am
Okay, I can see why you like GI there ,-)
You could use HDR, but the poor thing with TG2TP's OpenEXR-output is that it does not really contain much data to enhance detail in the shadows as well.
Title: Re: GI water and reflections problem
Post by: bigben on July 07, 2007, 08:02:08 pm
Rarcher, can you try a render with the detail dropped to 0.5   I found my GI problem to be linked to the detail level.. the higher the level the worse it got
Title: Re: GI water and reflections problem
Post by: Volker Harun on July 08, 2007, 02:44:30 pm
Attached two images - only difference is the surface.
The first shows GI-faults in the reflections. Surface is defined by altitude
The second one does show normal reflections with changed surfaces (only slope defined)
Volker
Title: Re: GI water and reflections problem
Post by: RArcher on July 09, 2007, 08:56:31 pm
BigBen, Here is the render with the detail down to 0.5... as you can see the problem completely disappears.  The previous renders with the problems were done at 0.7.  You are on to something here...
Title: Re: GI water and reflections problem
Post by: Volker Harun on July 10, 2007, 04:13:20 am
Interesting. The first picture I uploaded was Detail .25 - the second one with .38.
I have the files at home and will re-check it.
Volker
Title: Re: GI water and reflections problem
Post by: bigben on July 15, 2007, 06:52:19 pm
Quote from: Volker Harun on July 10, 2007, 04:13:20 am
Interesting. The first picture I uploaded was Detail .25 - the second one with .38.
I have the files at home and will re-check it.
Volker


I think your problem is more related to reflection issues than GI.
Title: Re: GI water and reflections problem
Post by: bigben on July 15, 2007, 07:01:43 pm
Quote from: RArcher on July 09, 2007, 08:56:31 pm
BigBen, Here is the render with the detail down to 0.5... as you can see the problem completely disappears.  The previous renders with the problems were done at 0.7.  You are on to something here...


I'm just about to post another test render to my series (been away on holidays). If it is related, then we have two examples of the problem at different scales. My series of images clearly shows the problem gets worse with increasing detail, spreading from the opposite side of the planet. 
Title: Re: GI water and reflections problem
Post by: Oshyan on July 20, 2007, 01:47:02 am
Reducing GI to 1:1 or increasing to 8:8 seems to solve the problem. Obviously 8:8 gives more detailed lighting but at tremendous render cost. If the detail lost at 1:1 is not prohibitive then you might give that a try. Of course it may reoccur on some of the other frames.

I do think this scene is a good testbed for these odd GI accuracy and blending issues though so I'm going to pass it on to dev.

- Oshyan