Planetside Software Forums

Support => Terragen Support => Topic started by: archonforest on August 10, 2017, 04:12:44 PM

Title: Can't download
Post by: archonforest on August 10, 2017, 04:12:44 PM
Trying to get 4.1 but getting errors message saying not valid email.  I tried with 3 different addresses but non worked. Is this happening because I try to download it with my phone?
Title: Re: Can't download
Post by: Oshyan on August 11, 2017, 06:45:58 PM
Strange. I take it you're downloading the free version? Depending on the phone it should work, but of course... you can't *run* it on your phone. ;) Also if you have an ad or script blocker that could cause problems.

I've just tested it now and it's definitely working, at least in Firefox.

- Oshyan