Planetside Software Forums

General => Terragen Discussion => Topic started by: pixelsmack on March 29, 2019, 01:26:53 am

Title: Sun visible through clouds needs work? Or do I suck?
Post by: pixelsmack on March 29, 2019, 01:26:53 am
So I know you can turn off visible sun and add your own in comp later. That's fine. But it seems that with Terragen's amazing clouds and atmosphere it could render the sun more "correct" through clouds? Softer, more diffuse? Instead of what looks like a hard edge ball? I even wrote out EXRs as normal and tried to pull it down. Didn't work so well. The attached image is RAW ungraded.

I'm not knocking the app at all. I may be doing something wrong or I understand it's a work in progress. It simply would be nice to have a more natural visible sun. Heck even if it's a "fake" softening option, would be awesome.

P.S. We bought a permanent license for those tracking my other thread. Thanks for your help!

Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: bobbystahr on March 29, 2019, 11:02:21 am
That's always bugged me as well and have ceased trying to get that effect.
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: SuddenPlanet on March 29, 2019, 03:47:04 pm
#1 - You don't Suck!  ;)

Have you tried turning off "Visible disc"? in the Sunlight node?
Also make sure to keep "Glow in atmosphere and clouds" turned on.

-Derek
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: Matt on March 29, 2019, 03:55:22 pm
As far as I recall, this is a problem with "defer atmo/cloud" that goes away if you turn that off. But I wouldn't recommend that solution - it would be better to turn the sun disc off. I'm trying some different combinations of cloud settings right now and I will let you know if I find something that works. If not, we'll mark this as a bug that needs to be fixed.
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: SuddenPlanet on March 29, 2019, 04:21:49 pm
Here is what it looks like with the Sun Disc off:
[attachimg=1]

-Derek
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: pixelsmack on April 03, 2019, 06:25:25 pm
Fantastic! I can work with this. When we pop above the clouds, I can comp in a "sun disc."

Adding these tips to my TIP SHEET.
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: Oshyan on April 03, 2019, 08:16:29 pm
Normally you probably won't even see the sun disc because the area around the sun is so bright from glow (when you are in the atmosphere). You should only need to comp a sun disc in if you go above the atmosphere into space, I think.

- Oshyan
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: pokoy on May 03, 2019, 01:51:13 pm
Quote from: Matt on March 29, 2019, 03:55:22 pm
As far as I recall, this is a problem with "defer atmo/cloud" that goes away if you turn that off. But I wouldn't recommend that solution - it would be better to turn the sun disc off. I'm trying some different combinations of cloud settings right now and I will let you know if I find something that works. If not, we'll mark this as a bug that needs to be fixed.


I've just run into this, the sun sits nicely right in front of the clouds although it's a really thick cloud layer. Should I submit this as a bug? Not sure if it's on the radar already or not...
It's a still image in my case but I imagine this being a problem in animations where you may need the sun disc to remain visible.
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: Matt on May 03, 2019, 09:31:45 pm
Yeah, please do. Thanks.
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: icarus51 on May 10, 2019, 04:51:51 am
Hi all.

A curiosity about this issue that is probably a bug. I tried various renders, with Terragen 4 and 3 but the problem was always present, if Defer Atmo/Cloud is On.

There is nevertheless a strange thing. In the preview Window the sun is always hidden (?). Another bug or what?

Also in Terragen 3 the same thing happens. The sun is not seen in Preview but it appears in Render. Perhaps is it useful to fix the problem?

Or I'm missing something.

Greetings

Ps: I forgot: this is the crop of the file in Preview. The sun (disc) is well present.
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: Oshyan on May 10, 2019, 06:51:17 pm
There is discussion above about this. Some aspects of it are a bug, though potentially minor. But the solution for now is to disable Visible Disc in the Sunlight node. Did you try that?

- Oshyan
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: icarus51 on May 14, 2019, 05:34:42 am
Hi Oshyan.

Sure.
To date, it is the only solution to the problem. I just wanted to point out that it doesn't appear in Preview (the reason for this i don't know).
Title: Re: Sun visible through clouds needs work? Or do I suck?
Post by: icarus51 on May 25, 2019, 09:20:09 am
Hi Folk.
The problem of the solar disc in front of the clouds with Defer Atmo/Cloud on solves with Defer All Shading On.
I experimented with various attempts and put an image  where the solar disc appears halfway between cloud and sky.
Even with Defere All Shading and Defer Atmo/Cloud activated at the same time the problem is avoided.
I don't know in the animation but for the still images the problem is solved, even if the rendering time certainly grows.
Try and see.
Of course, you can always put Visible Disc Off and Stop with this issue. :)