Planetside Software Forums

Support => Terragen Support => Topic started by: ross on February 10, 2008, 08:08:28 am

Title: I can't run TG v0.9
Post by: ross on February 10, 2008, 08:08:28 am
Hey, first off, I love Terragen, it's one of those programs that i spend ages trying to get good at :)

Secondly, I can't seem to run 0.9. TG2 works fine, but everytime i try to boot up 0.9, it tells me:

QuoteComponent COMDLG32.OCX or one of its dependencies not correctly registered: a file is missing or invalid.


I'm running Vista Home Premium, 3GB RAM, 2x2ghz processor etc. and i've also tried to reinstall.

Hope it can be fixed
Title: Re: I can't run TG v0.9
Post by: Matt on February 10, 2008, 11:37:34 pm
The Terragen installer should put the file comdlg32.ocx in this folder on your hard drive: C:\WINDOWS\system32\

Can you check to see if the file is in there? It was probably there before Terragen was installed, preventing the Terragen installer from replacing the file. Normally that is OK but if the file had been corrupted for some reason by another program then the Terragen installer would be unable to fix it. I would suggest that you delete the file (make a backup copy of the file first), uninstall Terragen and then try running the Terragen installer again. Please give this a try and let us know how it goes.

Matt
Title: Re: I can't run TG v0.9
Post by: ross on February 11, 2008, 03:13:13 am
Hmm, didn't work.

It seems that whenever I delete it, it restores itself...

any other ideas?
Title: Re: I can't run TG v0.9
Post by: Oshyan on February 11, 2008, 10:40:40 pm
This may be a Vista issue. Did you install with Administrator privileges?

- Oshyan
Title: Re: I can't run TG v0.9
Post by: ross on February 12, 2008, 04:37:10 am
yeah, i've got admin privs.

all I can think of is installing it on an XP pc, then copying the COMDLG file over and replacing it here.  Does that idea have merit?
Title: Re: I can't run TG v0.9
Post by: Matt on February 12, 2008, 09:29:59 pm
I think that should work, yes.

Matt