Planetside Software Forums

Support => Terragen Support => Topic started by: king_tiger_666 on January 08, 2007, 04:39:28 PM

Title: terragen 2 crashs when attempting to move camera
Post by: king_tiger_666 on January 08, 2007, 04:39:28 PM
when i go to rotate the camera with the alt+RMB, terragen 2 quits out of the terragen tga file i have open...  is this a known bug in terragen?....

Title: Re: terragen 2 crashs when attempting to move camera
Post by: Oshyan on January 10, 2007, 12:55:41 AM
I'm not aware of that bug. Does it do this every time, or just sometimes? Btw I think you mean tgd or "project" - tga is an image format. :)

- Oshyan
Title: Re: terragen 2 crashs when attempting to move camera
Post by: king_tiger_666 on January 10, 2007, 01:04:01 AM
you are right about the file extention...

i toggled each thing off and on and it seems to only crash when the fake stone shaders where enabled... so i disabled them prior the final render..

Title: Re: terragen 2 crashs when attempting to move camera
Post by: Oshyan on January 10, 2007, 01:35:30 AM
It would be helpful if you could provide a file to illustrate this issue as it's not one we have seen previously.

- Oshyan
Title: Re: terragen 2 crashs when attempting to move camera
Post by: king_tiger_666 on January 10, 2007, 03:50:07 AM
ok this is the file i had problems with.. attached at bottom... if you disable the shaders it will allow you to rotate the camera... but it might be caused by my experimenting... who knows but any help would be great.. maybe stop this happening again

the final version of this file can be found here http://homepages.slingshot.co.nz/~rawjdmbj/downloads/render8.zip

Title: Re: terragen 2 crashs when attempting to move camera
Post by: Oshyan on January 21, 2007, 09:22:19 PM
Sorry for the delay in responding. Unfortunately I'm unable to duplicate your issue with the provided .tgd. Alt+RMB is not "rotate", it's translate/"pan" in most configurations. I tried all the mouse configuration options but had no crashes. All layers were enabled. There was no object to load and several textures were missing as well. Could you possibly provide a more simplified .tgd file to exemplify this particular issue?

Thanks!

- Oshyan
Title: Re: terragen 2 crashs when attempting to move camera
Post by: MeltingIce on January 22, 2007, 04:11:44 PM
This has happened to me too, whenever I try to move the camera in any direction, TG2TP crashes.  I attached the .tgd for you.
Title: Re: terragen 2 crashs when attempting to move camera
Post by: ┬žardine on January 22, 2007, 10:42:23 PM
Quote from: MeltingIce on January 22, 2007, 04:11:44 PM
This has happened to me too, whenever I try to move the camera in any direction, TG2TP crashes.  I attached the .tgd for you.

Your image map shader is set to projection type: through camera, but you don't have a camera specified
try changing the projection type or assigning a camera to it and I think this should fix you problem  :)

~Sardine
Title: Re: terragen 2 crashs when attempting to move camera
Post by: MeltingIce on January 22, 2007, 11:01:50 PM
Quote from: ┬žardine on January 22, 2007, 10:42:23 PM
Quote from: MeltingIce on January 22, 2007, 04:11:44 PM
This has happened to me too, whenever I try to move the camera in any direction, TG2TP crashes.  I attached the .tgd for you.

Your image map shader is set to projection type: through camera, but you don't have a camera specified
try changing the projection type or assigning a camera to it and I think this should fix you problem  :)

~Sardine
Ahh good call, I missed that little detail :P.  Works now, thanks
Title: Re: terragen 2 crashs when attempting to move camera
Post by: ┬žardine on January 22, 2007, 11:08:39 PM
np  ;)